Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP SLA+Track over EIGRP

Hi all,

I have a topology as below. I named links as A link (R1-R2-R4), B link (R1-R4 direct link), C link (R1-R3-R4). At first I want only link A and C to be used while loadbalancing for network 4.4.4.4 (Anounced by R4). If any of these links will fail, link B should loadbalance for network 4.4.4.4 with the alive link.

I've tried this to achieve what I am speaking of, I redirect eigrp traffic between R1 and R4 to R2 f0/0 as long as I can ping R2's f0/0 interface. If pinging to R2's f0/0 interface fails, R1 and R4 should be neighbor. So that, any failure of links A and C, link B will get involved in. Track is working well, I see track is down after I shut R2's f0/0 interface but the neighborship between R1-R4 is flipping even when track is up. I haven't seen something important while debugging. Configuration for related parts of R1 as below.

I have just worked on failure of A link, truly on f0/0 interface of R2.

 

 

ip sla monitor 1

type echo protocol ipIcmpEcho 192.168.24.4 source-interface FastEthernet0/0

timeout 1000

threshold 1000

frequency 1

ip sla monitor schedule 1 life forever start-time now

!

track 10 rtr 1 reachability

!

 

interface FastEthernet0/0

 

ip address 192.168.12.1 255.255.255.0

ip virtual-reassembly

delay 100

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.13.1 255.255.255.0

delay 100

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 192.168.14.1 255.255.255.0

ip policy route-map EIGRP

delay 2000

duplex half

!

router eigrp 100

network 0.0.0.0

metric weights 0 0 0 1 0 0

no auto-summary

eigrp router-id 192.168.12.1

neighbor 192.168.14.4 FastEthernet1/0

!

ip local policy route-map EIGRP

!

!

!

ip access-list extended EIGRP

permit eigrp host 192.168.14.1 host 192.168.14.4

!

route-map EIGRP permit 5

match ip address EIGRP

set ip next-hop verify-availability 192.168.12.2 1 track 10

!

route-map EIGRP permit 10

679
Views
0
Helpful
0
Replies
CreatePlease to create content