Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

MPLS ldp session troubleshooting

Two MPLS enabled routers (R1 and R2)  are connected via a switch (vlan 10).

R1:0/0 - Sw1:0/0

R2:0/0 - Sw1:0/1

 

Configuration:

 

SW1#

interface range Ethernet0/0 - 1

  switchport access vlan 10

 

R1#

conf t

mpls ip

!

interface Ethernet0/0

  ip address 10.10.10.1 255.255.255.0

  mpls ip

!

interface Loopback0

  ip address 150.1.1.1 255.255.255.255

!

router ospf 1

  network 0.0.0.0 255.255.255.255 area 0

 

 

R2#

conf t

mpls ip

!

interface Ethernet0/0

  ip address 10.10.10.2 255.255.255.0

  mpls ip

!

interface Loopback0

  ip address 150.1.2.2 255.255.255.255

!

router ospf 1

  network 0.0.0.0 255.255.255.255 area 0

 

Verification:

 

R1# sh mpls ldp nei

! no result

 

R1# ping 224.0.0.2

Reply to request 0 from 10.10.10.2, 6 ms

 

R1(config)# access-list 101 permit udp any any

R1# debug ip packet detail 101

IP: s=10.10.10.1 (local), d=224.0.0.2 (Ethernet0/0), len 62, sending broad/multicast

UDP src=646, dst=646

 

R1# debug mpls ldp transport events

ldp: Send ldp hello; Ethernet0/0, src/dst 10.10.10.1/224.0.0.2, inst_id 0

 

How to up the MPLS ldp session?

Note: When R1-R2 routers are directly connected (not via switch), MPLS ldp session is up.

Everyone's tags (2)
243
Views
0
Helpful
0
Replies
CreatePlease to create content