Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

VMWare Tools install still blocked with 10.5(1)

I just upgraded CUCM and CUCX from 9.1 to 10.5(1) and ran into the issue described in CSCul78735 so it doesn't appear completely fixed. I wasn't able to upgrade VMWare Tools until setting SELinux to permissive mode.

Everyone's tags (1)
8 REPLIES

Hi Eric, Are you still facing

Hi Eric,

 

Are you still facing this issue in the fixed version ?

 

Which of the below method did you follow to upgrade the VMtools ?

 

+ Interactive Tools Upgrade

+ Automatic Tools Upgrade

+ Automatic tools upgrade from vcenter

+ Upgraded ESXi which triggered the VM tools upgrade

 

Regards,

Gagarin

Regards, Gagarin Please rate all helpful posts.
New Member

Hi Gagarin,I tried every

Hi Gagarin,

I tried every upgrade procedure and none worked. As I recall, the automatic upgrade from VCenter left the servers showing VMWare Tools not installed until they were rebooted and then they still showed out-of-date. The interactive upgrade left the out-of-date version on after reboot also.

I can't remember what method I used after setting SELinux to permissive but it worked without any issues. I probably did the Automatic Upgrade because it's the easiest.

The ESXi version is 5.1.0, 1612806.

Thanks,

Eric

Hi Eric, Thanks a lot for the

Hi Eric,

 

Thanks a lot for the update.

 

By any chance in the near future if you are scheduled to do any UC application upgrade which would involve VMWare tools upgrade as well and should you run into the issue, please let me know before performing the workaround ( if possible ) . Would like to take a look into the issue since it is intermittent and is not just isolated to CUCM.

 

Regards,

Gagarin

Regards, Gagarin Please rate all helpful posts.
New Member

Gagarin,I too, have run into

Gagarin,

I too, have run into this problem. I have not applied the workaround, as of yet.

Attached is my migration/upgrade plan.

Dell

Hello, Please send across the

Hello,

 

Please send across the below logs for the timeframe covering the VMWare tools upgrade failure.

 

+ Cisco Audit Logs

+ Event Viewer-Application Log

+ Event Viewer-System Log

 

Please mention the current  CUCM version as well.

 

Regards,

Gagarin

 

 

Regards, Gagarin Please rate all helpful posts.
New Member

Hi Gagarin, I have recently

Hi Gagarin,

 

I have recently upgraded 5 servers to 10.5.2.11900-3.  With 2 servers I tried updating the VMware tools automatically through the vSphere client.  The result was that the VMware tools were uninstalled from the VM.  With the other 3 servers I selected the interactive install and used the 'utils vmtools refresh' command.  Updating the tools on these 3 servers was successful.  On the 2 servers that were not successful I am unable to use the 'utils vmtools refresh' command because I get a message stating "No VMware Tools install currently exists on the system...restart the system..." but after multiple reboots VMware tools still do not reinstall.  I have set the 'utils os secure permissive" but that has not helped.  The tools have now been uninstalled and I can not find a method to reinstall without TAC.  TAC could probably install from root but instead has only emailed and recommended that I install a mystery COP file but they have not provided information on where I can locate a COP file for 10.5 and I believe that is because there is not a COP file available.  If you would still like to troubleshoot this issue please let me know.

 

For others looking to upgrade the VMware tools I recommend the approach of using the 'utils vmtools refresh' command from the cli.

Hello, Please let me know the

Hello,

 

Please let me know the TAC SR number.

 

Thanks,

Gagarin

Regards, Gagarin Please rate all helpful posts.
New Member

I run into this issue with 10

I run into this issue with 10.5.2, seems the vmx file needs to be edited to allow vmware tools update from within the guest OS.

 

Refer to this article on the VMWare website : http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2007298

848
Views
0
Helpful
8
Replies
CreatePlease login to create content