Cisco Support Community

After an upgrade from Cisco Unity 3.x to 4.x, the user receives a "License Violation" error in EventViewer

Core Issue

After upgrading Cisco Unity from version 3.x to 4.x, the user receives this EventViewer license violation error:

Error 0x331A

Licensing violation

Description: This Unity server is using one or more features

for which it has insufficient licenses.

Until the problem is corrected, Unity will

stop answering calls every four hours,

and you will need to manually restart the AvCsMgr service.

After four hours, the AvCsMgr service needs to be manually restarted.


This could be a valid license violation. If you do not have the neccessary licenses e-mail, refer to

This could also be a common problem caused by the default class of service template that has the Visual Messaging Interface (VMI) feature enabled for subscribers, where there are no licenses for VMI.

To check this, perform these steps:

  1. Open the Unity System Administration web pages.
  2. Under System, select Licensing.
  3. If the Used count is higher than the Total count for Cisco Unity Inbox Subscribers (and the Total count is 0), this problem may occur.

To fix this issue, disable the Unity Inbox feature by performing these steps:

  1. Open Unity System Administration web pages.
  2. Under Subscribers, select Class of Service.
  3. For each Class Of Service configured, select Licensed Features, uncheck Cisco Unity Inbox and save.

This issue is documented in Cisco bug ID CSCea16377 - Unity goes down every 4 hours.