Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

An IP phone controlled by CallManager across a low speed WAN link exhibits poor performance including delayed dial tone and resets

Core Issue

The issue is that the remote IP phone has no dial tone and does not hang up or reboot.

The Low Latency Queueing (LLQ) was correctly configured for voice. The signaling protocols, however, are not receiving sufficient priority for the phone to be properly controlled.

These are the symptoms:

  • The IP phone does not hang up after the termination of an incoming call from the private ISDN network. The End Call button needs to be pressed several times to end the call. After the End Call button is pressed, the phone reboots.
  • The IP phone produces the problem for the first time dialing to the outside line or to the central site. A dial tone is not received, even though the phone appears to have dialed the number. The Cancel button needs to be pressed several times to end the outgoing call. After this procedure, the phone reboots. When the same numbers are dialed once more, there are no problems.
  • The phone intermittently loses connectivity to Cisco CallManager.

Resolution

This situation is for home users of IP Telephony who are controlled by a centralized Cisco CallManager across an ISDN link.

LLQ was properly configured for voice but not for the signaling protocols. In this case, the signaling protocol is Skinny Client Control Protocol (SCCP). LLQ needs to be configured to ensure that these signaling and voice ports receive appropriate priority:

  • Real Time Protocol (RTP): User Datagram Protocol (UDP) ports 16384 to 32768
  • H.225 : Transmission Control Protocol (TCP) port 1720
  • H.245 : TCP ports 11000+
  • SCCP: TCP 2000 2002

This is a sample configuration:

class-map match-all VoIP-Control
match access-group 104
class-map match-all VoIP-RTP
match access-group 103
!
policy-map VOICE
class VoIP-Control
bandwidth 10 
!--- 8K is for call control.
class VoIP-RTP
priority 30 
!--- This is used for a single G729 call.
class class-default
fair-queue
!
interface Multilink1
bandwidth 64
ip address 10.1.1.1 255.255.255.0
no ip redirects
no ip mroute-cache
max-reserved-bandwidth 100
service-policy output VOICE
no cdp enable
ppp multilink
ppp multilink fragment-delay 10 
!--- This fragments large packets.
ppp multilink interleave 
!--- This will interleave voice and fragmented data packets. 
multilink-group 1
!
interface Serial2/0
no ip address
encapsulation ppp
no ip mroute-cache
no fair-queue
ppp multilink
multilink-group 1
!
access-list 103 permit udp any any range 16384 32767
access-list 104 permit tcp any any eq 1720
access-list 104 permit tcp any any gt 11000
access-list 104 permit tcp any any range 2000 2002

For more information, refer to these documents:

Version history
Revision #:
1 of 1
Last update:
‎06-22-2009 05:34 PM
Updated by:
 
Labels (1)