Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

AutoQoS for VoIP

Core Issue

Cisco AutoQos is a Cisco IOS  Software feature that automatically provisions Cisco IOS QoS features for voice traffic for Cisco router and Cisco Catalyst switch platforms.

Cisco AutoQoS automates consistent deployment of QoS features across Cisco routers and switches. It enables various Cisco QoS components based on the network environment and Cisco best-practice recommendations. With the increased prominence of delay-sensitive applications (voice, video, and other multimedia applications) deployed in networks today, proper QoS configuration ensures high-quality application performance.

You must have a thorough understanding of various QoS features (such as queuing, dropping, traffic conditioning, queue-depth, drop thresholds, burst parameters, LFI, and cRTP) and the complexities of configuring many parameters associated with these features. Cisco AutoQoS helps overcome these difficulties by automatically configuring the device for Cisco QoS features and variables with the correct parameters.

Users can subsequently tune parameters that are generated by Cisco AutoQoS to suit their particular application needs.

Cisco AutoQoS VoIP feature is supported only on these interfaces and PVCs:

  • Serial interfaces with PPP or High-Level Data Link Control (HDLC)
  • Frame Relay Data-Link Connection Identifiers (DLCIs)(point-to-point sub-interfaces only)
  • ATM Permanent Virtual Circuits (PVCs)

This table shows the availability of Cisco AutoQos:

PlatformsSoftware
Switches

Cisco Catalyst 2950EI

Cisco Catalyst 3550

Cisco IOS Software Release 12.1(12c)EA1

Cisco Catalyst 4500

Cisco IOS Software Release 12.1(19)E

Cisco Catalyst 6500

Cisco Catalyst Operating System 7.5.1

Routers

Cisco 2600/2600-XM Series

Cisco 3600 Series

Cisco 3700 Series

Cisco 7200 Series

Cisco IOS Software Release 12.2(15)T

Resolution

These sample configurations show the same Cisco IOS configuration, first with AutoQoS and then with manual configuration techniques:

Cisco AutoQoS:

interface Serial0
bandwidth 256
Ip address 10.1.61.1 255.255.255.0
Autoqos voip

Manual QoS:

interface Multilink1

ip address 10.1.61.1 255.255.255.0

ip tcp header-compression iphc-format

load-interval 30

service-policy output QoS-Policy

ppp multilink

ppp multilink fragment-delay 10

ppp multilink interleave

multilink-group 1

ip rtp header-compression iphc-format

!

interface Serial0

bandwidth 256

no ip address

encapsulation ppp

no ip mroute-cache

load-interval 30

no fair-queue

ppp multilink

multilink-group 1

class-map VoIP-RTP

match access-group 100

!

class-map VoIP-Control

match access-group 101

!

policy-map QoS-Policy

class VoIP-RTP

priority 100

!

class VoIP-Control

bandwidth 8

!

class class-default

fair-queue

access-list 100 permit ip any any precedence 5

access-list 100 permit ip any any dscp ef

access-list 101 permit tcp any host 10.1.10.20 range 2000 2002

access-list 101 permit udp any host 10.1.10.20 2427

access-list 101 permit tcp any host 10.1.10.20 2428

!

access-list 101 permit tcp any host 10.1.10.20 1720

access-list 101 permit tcp any host 10.1.10.20 range 11000 11999

The show autoqos interface command is available to verify the actual QoS configuration commands provisioned by configuring AutoQos.

For more information, refer to these documents:

1045
Views
0
Helpful
0
Comments