Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

CME GUI issues if GUI files are copy-pasted from a laptop to flash

Problem Description:

Could not navigate on the CME GUI. Page would open up but menu options would not have any thumbnails and we could not click on the same.

Debugs collected: “debug ip http all”. No difference seen in a working scenario (taken from a lab router where the GUI was working) and a non working scenario.

Troubleshooting done:

1.       Could navigate to the page but could not access any of the menu options.

2.       Added the ip http authentication local command and checked ancillary commands on GW.

3.       Checked the CME GUI files. Found that the versions were incorrect. Downloaded the correct version and copied the files over to flash.

4.       Same issue observed. Pings working fine.

5.       Disabled the firewall and made sure that there aren’t any ACLs blocking traffic.

6.       Changed the browser, reduced security settings and downloaded the latest version of Java.

7.      Found that there were files which had been changed to uppercase while copy-pasting them from the laptop to flash. These files were:

DOM.JS
LOGOHOME.GIF
SXICONAD.GIF
UPARROW.GIF

Cisco's file system is case-sensitive (it would consider "readme.txt" and "README.TXT" as two different files). So I made a copy of the four files listed above, making the filenames lower-case and then deleted the uppercase files. After that, the CME GUI worked.

Appears as if it changes ONLY these 4 file names to uppercase. An IOS upgrade was done without any issues in a similar way and the GUI files when copied over to another flash from the laptop exhibit the same behavior – tried with multiple platforms and multiple GUI versions.

Hope this saves some time!!!

Comments
New Member

This helped tremendously!  I have no idea why it converts the file to all caps since you can transfer IOS images to flash with no alteration from a windows machine with a card reader.  Anyways this was the only reference I could find to this on the internet and it was a big help.  Thanks again.

New Member

THANK YOU! This saved my life !

Rgds

Marco.

New Member

AWESOME,AWESOME,AWESOME. I spent an entire day trying different loads and IOS but kept failing. found this is a bit of desperation and it solved my issue. thank you very much!!!

New Member

Super!!!!! Helped me save a lot of time..
 

2091
Views
15
Helpful
4
Comments