Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

CTL client error: Version is not compatible with CTL provider

Description:

This is related to CSCtr38292. After upgrade to CUCM 8.5.1SU2 CTL client can't connect to the CUCM with error:"CTL Client version is not compatible with the CTL Provider".

Getting the fix:

The only version impacted by this is 8.5.1.12900-7 and the fix is available in CUCM ES version 8.5.1.13028. Contact TAC to obtain the fix version.

Symptoms

CTL client can't connect to the server with error: "CTL Client version is not compatible with the CTL Provider"

Client log:

07/03/11 01:34:46:EnvelopeWriter:Waiting for reply from Provider

07/03/11 01:34:46:EnvelopeWriter:Doing SSL Read

07/03/11 01:34:46:EnvelopeWriter:SSL_read succeded 28

07/03/11 01:34:46:EnvelopeWriter:msg id = 17 msg len = 8

07/03/11 01:34:46:EnvelopeWriter:Message Type is GetCTLVersionResponse

07/03/11 01:34:46:EnvelopeWriter:SSL Send done retVal = 0

07/03/11 01:35:06:EnvelopeWriter:CServerInfoDialog::ValidateData done.

ErrorCode=25004

Server log:

01:28:38.673 HDR|07/03/2011

CTLPROV,StandAloneCluster,10.0.40.11,Error,8.5.1.12900-7

01:28:38.673 |   CCTLServerSocket::TLSReceive TCP connection is ready.

Do server side SSL.

01:28:46.178 |   CCTLServerSocket::TLSReceive SSL Handshake could not be

completed. Retrying ...

01:34:45.559 |   CCTLServerSocket::TLSReceive TCP connection is ready.

Do server side SSL.

Version history
Revision #:
1 of 1
Last update:
‎08-25-2011 01:17 PM
Updated by:
 
Labels (1)
Comments
New Member

Hello,

I have the same error message on a CUCM with the System version: 8.5.1.14046-1

Now to verfy that it is really the Bug, I want to check the Server and Client Log. But I don't know how to get them. Can you give me an advice?

Thank's!

Regards,

Matthias

The Client Log can be viewed in by going to

C:\Program Files (x86)\Cisco\CTL Client\Trace

The highest CTLtrace file will be the last log.  I am currently trying to troubleshoot an issue with the CTL Client V5.0 myself.  The client appears to connect to the server and sign in and then the CTL software stops responding.

This is course maybe an issue for another post.  Just thought I would share that little bit with you now.

New Member

I now have the same error with Version 9.1.1.10000-11

It was working before - then I generated CSR for ipsec and uploaded the signed certificate for ipsec. After that I wanted to update CTL file and it hasn't worked anymore.

 

Did I break it with the signed certificate from my CA for the ipsec on CUCM?

New Member

changed the ipsec cert back to self signed.

after that CTL file update was possible again.

Hello everyone, I have the same error in CUCM 10.5.1.10000-7.

Somebody know if this bug is in new version?

New Member

Hello,

 

For me, this worked:

changed the ipsec cert back to self signed.

after that CTL file update was possible again.

 

Hi David, the issue is before update CTL File, just only for Mixed Mode and the CTL Client send the error.

 

Today convert CTL CUCM in mixed mode via CLI server, the TAC engineer help me with this problem.

 

Tonight restart services (CUCM and CTL) and will do deployment in the phones.

I will keep you informed

 

New Member

Hello,

 

we have the same Bug with CUCM 7.1.5 Version.

 

The following certificates were regenerated:
callmanager.pem
capf.pem
ipsec.pem
tomcat.pem (only on the subscribers, tomcat on the publisher will not expire yet)

 

changed the ipsec cert back to self signed.

However, after regenerating the certificates, the Cisco CTL client can no longer
connect to the publisher, it displays an error message:
CTL Client version is not compatible with the CTL Provider

So we are unable to write the new CTL file.

If we enter the IP address of a subscriber in CTL client, instead of the IP of
the publisher, then the CTL client can connect.

 

 

Regards,

Efraim

changed the ipsec cert back to self signed.