Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

CUBE High Availability (HA) Configuration on ISR-G2

 

 

Introduction

This document covers the configuration procedure on Cisco Unified Border Element (CUBE) High Availability (HA) HSRP Configuration on ISR-G2 Box-to-Box failover.

 

CUBE Configuration on ISR-G2 Box-to-Box Failover

 

Below configuration tested on Cisco IOS Release 15.1.2T release on ISR-G2 Box-to-Box Failover dual attached.

 

cube-ha-1.png

 

cube-ha-2.png

 

Sample configuration on Acitve Box - ISR-G2

 

 

redundancy inter-device

scheme standby SB

!
!-- scheme standby SB - Single Scheme Supported

 

voice service voip

mode border-element

allow-connections sip to sip

redundancy

!

!-- redundancy - Trun on CUBE checkpointing on both Active and Standby Box

 

 

Basic HSRP Configuration

 

ipc zone default

association 1

no shutdown

protocol sctp

local-port 5000

local-ip 10.10.24.14

remote-port 5000

remote-ip 10.10.24.13

!

 

Outside i/f: HSRP group 0

 

interface GigabitEthernet0/0

ip address 10.10.25.14 255.255.255.0

standby version 2

standby 0 ip 10.10.25.1

standby 0 priority 50

standby 0 name SB

bfd interval 500 min_rx 500 multiplier 3

!

 

Inside i/f: HSRP group 6 Configuration

 

interface GigabitEthernet0/1

ip address 10.10.24.14 255.255.255.0

standby version 2

standby 6 ip 10.10.24.1

standby 6 priority 50

standby 6 track 1 decrement 10

bfd interval 500 min_rx 500 multiplier 3

 

 

 

Sample configuration on Standby Box - ISR-G2

 

 

redundancy inter-device

scheme standby SB

!

!-- scheme standby SB - Single Scheme Supported

 

voice service voip

mode border-element

allow-connections sip to sip

redundancy

!

!-- redundancy - Trun on CUBE checkpointing on both Active and Standby Box

 

Basic HSRP Configuration

 

ipc zone default

association 1

no shutdown

protocol sctp

local-port 5000

local-ip 10.10.24.13

remote-port 5000

remote-ip 10.10.24.14

!

 

Outside i/f: HSRP group 0

 

interface GigabitEthernet0/0

ip address 10.10.25.13 255.255.255.0

standby version 2

standby 0 ip 10.10.25.1

standby 0 priority 50

standby 0 name SB

bfd interval 500 min_rx 500 multiplier 3

!

 

Inside i/f: HSRP group 6 Configuration

 

interface GigabitEthernet0/1

ip address 10.10.24.13 255.255.255.0

standby version 2

standby 6 ip 10.10.24.1

standby 6 priority 50

standby 6 track 1 decrement 10

bfd interval 500 min_rx 500 multiplier 3

 

 

 

Configuration on both Active and Standby Box - ISR-G2

 

 

Bind traffic destined to the outside (SP SIP trunk) to the outside HSRP address

 

dial-peer voice 100 voip

description to-SIP

destination-pattern 9T

session protocol sipv2

session target ipv4:x.x.x.x

voice-class sip bind control source-interface GigabitEthernet0/0

voice-class sip bind media source-interface GigabitEthernet0/0

!

Bind traffic destined to the inside (CUCM or IP-PBX) to the inside HSRP address

 

dial-peer voice 200 voip

description to-CUCM

destination-pattern 555….

session protocol sipv2

session target ipv4:y.y.y.y

voice-class sip bind control source-interface GigabitEthernet0/1

voice-class sip bind media source-interface GigabitEthernet0/1

!

 

Configure media inactivity feature to clean up any calls that may not disconnect after a failover

 

ip rtcp report interval 3000

!

gateway

media-inactivity-criteria all

timer receive-rtcp 5

timer receive-rtp 86400

 

 

Troubleshoot


These show and debug commands are useful during troubleshooting of box-to-box redundancy:

 

The following is a summary list of the show commands useful during troubleshooting of B2B HA:

 

show redundancy application group all

show redundancy application transport clients

show redundancy client domain all | inc VOIP RG

show voice high-availability summary

show voip fpi stats

 

show redundancy state

show redundancy inter-device

show standby brief

show standby internal

show sip-ua status

show sip-ua statistics

show voip rtp connection | include connection

show arp

 


The following is a summary list of the debugs useful during troubleshooting of B2B HA:

 

Debug voip rtp session

Debug voice high-availability all

Debug voip fpi all

debug redundancy application group <config | faults | media | protocol | rii |

transport | vp>

 

debug voip ccapi all
debug voip ccapi error
debug voip rtcp session
debug voip rtp error
debug voip rtcp error
debug voice high-availability error
debug ccsip info
debug ccsip messages
debug ccsip media
debug ccsip error
debug standby terse

 

 

Related Information

 

Version history
Revision #:
2 of 2
Last update:
‎08-29-2017 11:36 AM
 
Labels (1)
Comments
New Member

Hi Muthurani,

Thank you for this good document.

Can we use VRRP instead of HSRP for this same configuration ?

Thank you in advance,

Haitham

Cisco Employee

Nice Doc.....

One thing to note

bfd should not be configured on HA CUBES - leads to unexpected reloads.


					
				
			
			
			
				
New Member

Good Job.

 

However, bfd command MUST NOT be used/configured along with SIP HA config. It will crash the standby router during HA switchover. I personally had to deal with this issue last year with a customer. They had CUBE HA setup, with bfd. Everytime active CUBE failed, the other would fail during switchover as well. Cisco TAC pointed to bfd setup within the CUBE HA config.