Cisco Support Community

CUCIMOC Login Fails with the error message "Failed to connect to CCMCIP authentication server"


Cisco  Unified Communications Integration for Microsoft Office Communicator (CUCIMOC) login falis with the following error messsage:

"Failed to sign in. Failed to connect to CCMCIP authentication server"


Try these steps:

  • This issue can happen when user's CUCM user ID case differs from CCMCIP database entries for this user.  CUCM login is NOT case sensitive, where CCMCIP is. As a workaround, standardize the case for user IDs (all lower case, for example). This is documented by Cisco Bug ID CSCsy15719.
  • Verify  that your LDAP Connection from CUCM to the LDAP actually works  You can create a user in your LDAP,  run the synch on the Callmanager and veirfy it is able to pull that user.

  • In your CUCM you will have an End User account which is used for CUCIMOC.  This user account may have any number of devices associated with it.  CUCIMOC only allows control of one device at a time, so the user will need to select the device they are controlling.  Refer the following document for configuring this:

    Configuring Servers for Cisco Unified Communications Integration for Microsoft Office Communicator: Creating Client Services Framework Devices and Directory Numbers for Users
  • CUPC 8 uses CCMCIP service on CUCM to retrieve the "controlled device". Make sure that you configured CCMCIP address correctly from CUPS > Application > Cisco Unified Personal Communicator.
  • Create or Modify the following registry key

    • HKEY_CURRENT_USER\Software\Cisco Systems, Inc.\Client Services  Framework\AdminData\CcmcipServerValidation
    • Type  : String / REG_SZ
    • Value : 0

    After that, kill cucsf.exe from Task Manager.

Known issues:

CSCso60232 User Authentication over SSL link to LDAP fails for CTI Manager.
CSCtd52910 LDAP Authentication over SSL not working via CTI.

This document was generated from the following thread: Deskphone disabled on CUPC release 8.x