Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

CUIC Reports Not Showing Up on all Subs

Recently had a case where it looked like replication wasn’t working and reports weren’t showing up under all 4 dashboards (they showed up under the same local dashboard but not the systems across the WAN).

A note about dashboards:  Dashboards are not only meant to display custom reports. Dashboards can contain reports, scheduled reports, web widgets, URLs, and sticky notes.

Assigning Reports to dashboard and giving permissions to users should work. In this case, development tried the following commands, but found it didn’t execute the “cdr realize” command.  >From Hari:

Executing CLI commands “utils dbreplication stop all”,  “utils dbreplication clusterreset” and “utils dbreplication reset all”  should have resolved customer issue, as these commands internally call “cdr realize” commands. 

Unfortunately, it did not work though we tried out couple of times. After going through replication logs,  we realized that “cdr realize” command failed to execute, I had run the same commands from linux shell to fix the replication issue.

Here’s the format for running cdr realize on each sub (CUIC has a pub and additional subs like Call Mgr so gets a bit confusing):

On pevtcuica2:

su -c 'ulimit -c 0;cdr realize template cuic_db_template g_pevtcuica2_ccm8_0_3_10000_581 ' – Informix

On pevtcuicb1:

su -c 'ulimit -c 0;cdr realize template cuic_db_template g_pevtcuicb1_ccm8_0_3_10000_581 ' – informix

On pevtcuicb2:

su -c 'ulimit -c 0;cdr realize template cuic_db_template g_pevtcuicb2_ccm8_0_3_10000_581 ' – Informix

A couple other tidbits.  To check if replication is working:

Could you check the following:

1.       Run CLI command "utils dbreplication status" and verify the

output, it should be something like below:



g_denver       1 Active   Local      0

g_miami        2 Active   Connected  0     Mar 19 13:48:44

g_usa          3 Active   Connected  0     Mar 19 13:48:40

g_france       4 Active   Connected  0     Mar 19 13:48:41

2.       Run the CLI command "utils dbreplication runtimestate", the

value of RPC column should "YES" and REPLICATION STATUS column should be


3.       Create dashboard from publisher node and verify whether the

same gets replicated onto any subscriber node.  If it is not replicated,

run the CLI "run sql select * from cuic_data:cuicdashboard" from

publisher and as well as from subscriber.   If the new dashboard entry

is there on publisher and subscriber nodes, then, we can say it is not

problem with replication and may be cache issue.  If it is cache issue,

click "Synchronize cluster" button from CUIC web page where dashboard is

not appeared.

If the output of CLI command "utils dbreplication status" shows other

than Active and Local/Connected, try to execute the following CLI

commands in sequence from publisher node CLI:

-          utils dbreplication stop all

-          utils dbreplication reset all

This is the part (step 3 above) that failed – you should be able to do this from the GUI interface.  Even running the commands mentioned above (“utils dbreplication clusterreset” and “utils dbreplication reset all”  ) did not replicate the reports to the other dashboards on other servers, so that’s when Hari ran the “cdr realize” and that resolved it.

For additional TOI info on CUIC, the link is: