Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

From CTS 1.7 no connection to screenshot link http://<IPPhone_IPADD>/CGI/Screenshot

After you upgrade CTS to 1.7 ,  you will not able to get IP Phone screen or connect to IP Phone via Phone remote application.
When you try to connect to screenshot link http://<IPPhone_IPADD>/CGI/Screenshot you will  receive following message CiscoIPPhoneError Number="4".

This problem didn't occur with CTS version 1.6 or lower version.

This is not a CTS 1.7.0 limitation but a CUCM/Phone limitation [Change with CUCM 8.0] . The phone asks the codec for authorization and now due
to security change the codec will deny the request starting release 1.7.

This is an unofficial workaround.

In 1.7 we have a limitation that we can get the screenshot for the Phone.

Able to access the screenshot for testing purposes only in following way.

1:Make sure the Authentication url is configured on the System >Enterprise parameters on the CUCM server Pointing to CUCM server
( Make sure the Hostname if that Url is Host name is resolvable by Phone)
2:Remove any authentication Server on the IP phone configuration.
Please make sure you reset the Phone so that the Authentication URL get Updated On Phone Via new TFTP config Phone Downloads on the reset.
3:As this phone is already controlled By Application user ( For this the CTSman Application user )
4:You can get the screen shot http://<Ip phone address>/CGI/Screenshot
5:Enter the CTSman account to log in to get the screen shot.

Comments

Does anyone know if this will be fixed in CUCM 7.xx or will we need to upgrade to 8.xx ?

New Member

@ Hans Dewulf:
Does "CUCM/Phone limitation [Change with CUCM 8.0]" mean

"changed with CUCM 8.0" or "will be fixed in CUCM 8.0" ?

I run into the same error here.
CUCM ver 7.1.3.32900-4

CTS ver 1.7.0.2(4719) P1

Phone 7975, load SIP75.8-5-3SR1S

Regarding your unofficial workaround: The cucm_cts_admin.pdf (see here) is not clear regarding phone config / the authentication URL:

- with SW 1.7 MIDlets are requiered

and

- page 2-10 (70 in pdf), table 2-6  says "Leave all fields blank to use the default." (this also means the "Authentication Server" field

So far IMHO your suggested workaround is good for daily use, no need to just temporarily remove the Auth URL from the Phone and configure it back.


BUT: page 2-19 (chapter "Configuring a Remote Phone") says
"...enter the following in the Authentication Server field: http://<your CTS IP Address>:8080/authenticate.html."

NOT differentiating between 1.7 SW or earlier SW, not differentiating between MIDlet/ non MIDlet Solutions.

and chapter Configuring the MIDlets IP Phone Interface Step 9 just lets me remove Service URL and Idle URL, says nothing about Authentication URL

-> So: am I right to leave it blank or is auth server URL in the Phone Config still necessary with 1.7 SW / MIDlets running??
(Asking here because i can test this at the earliest in 2 days)

regards

Thomas

2078
Views
0
Helpful
2
Comments