Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

How to route calls based on source IP address of SIP Invite on CUBE?

 

 

Introduction

 

This document covers the configuration procedures on how to route calls based on Source IP address of SIP Invite on Cisco Unified Border Element (CUBE).

 

Problem Description

 

Requirement/ Issue:

 

Sometimes there is a requirement to filter and route the calls only based on Source IP address of the SIP Invite from the Service Provider network.

 

Sample call flow and configuration example:

 

Sample configuration to test and route calls based on Source IP address of SIP Invite.

 

IP Phone A --> CUCM --> SIP --> CUBE(SBC) ---> SIP ---> CME ---> IP Phone B

 

Sample Test Configuration:

 

IP phone A (2125553000) calls IP phone B (4088536000)

Cisco Unified Communications Manager (CUCM) 200.1.1.70

CUBE (SBC) 200.1.1.3

CME 200.1.1.1

 

Solution

Here is the solution with the configuration commands to filter and route the calls from VOIP Network based on Source IP Address on CUBE.

 

Sample Configuration

 

Restriction of Incoming calls through CUBE can be implemented using the Voice Source Group and Access-list

 

Following command needs to be issued on the Gateway:

 

IPIPGW-11#sh run

Building configuration...

 

Current configuration : 4693 bytes

!

! Last configuration change at 16:35:28 PST Tue Dec 6 2012

! NVRAM config last updated at 16:35:28 PST Tue Fec 6 2012

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname IPIPGW-11

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

 

allow-connections sip to sip

sip

localhost dns:verizon.net

!

 

voice source-group test

! --- Create the Voice Source Group

access-list 1

! --- Access list that has IP address of the Origination end point - Source IP Address from CUCM

translation-profile incoming add111

! --- Translation profile to add prefix

 

!

voice translation-rule 1

! --- Translation rule to add prefix of 111

rule 1 /^4088536/ /1114088536/

!

voice translation-rule 2

! --- Translation rule to strip prefix of 111

rule 1 /^1114088536/ /4088536/

!

!

voice translation-profile add111

! --- Translation profile to add prefix to called number

translate called 1

!

voice translation-profile strip111

! --- Translation profile to strip prefix from called number

translate called 2

!

interface GigabitEthernet0/0

ip address 200.1.1.3 255.255.255.0

load-interval 30

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 1.3.222.77 255.255.0.0

ip virtual-reassembly

load-interval 30

duplex auto

speed auto

!

!

ip route 0.0.0.0 0.0.0.0 200.1.1.100

!

!

ip http server

!

access-list 1 permit 200.1.1.70

! --- Access list to permit the source IP Address of originating end point ie from Cisco Unified Communications Manager (CUCM).

!

!

!

dial-peer voice 2 voip

destination-pattern 212555....

session protocol sipv2

session target ipv4:200.1.1.70

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

!

dial-peer voice 4 voip

translation-profile outgoing strip111

! --- Translation profile to strip prefix

destination-pattern 1114088536...

! --- Destination-pattern MUST be prefixed string

session protocol sipv2

session target ipv4:200.1.1.1

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

!

line con 0

exec-timeout 0 0

privilege level 15

line aux 0

line vty 0 4

password cisco

!

scheduler allocate 20000 1000

ntp master 1

!

end

!

 

Debugs turned on for the IOS SBC

 

IPIPGW-11#sh deb

 

voip translation-rule

voip translation debugging is on (Filter is OFF)

 

voip source-group:

voip source-group debugging is on

CCAPI:

debug voip ccapi inout is ON (filter is OFF)

CCSIP SPI: SIP Call Message tracing is enabled (filter is OFF)

 

 

Related Information

 

Version history
Revision #:
2 of 2
Last update:
‎08-29-2017 11:16 AM
 
Comments
New Member

Nice work. I enjoyed reading it.