Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

How to update the Cisco CallManager, the IP Phones, the MCSs and the Cisco Unity in order to support the changes to DST in March 2007

Core Issue


In the spring of 2007, the start date and end date for daylight saving time (DST) change in order to comply with the Energy Policy Act of 2005. DST dates for 2007 in the United States and Canada start three weeks earlier, 2:00 A.M. on the second Sunday in March, and end one week later, 2:00 A.M. on the first Sunday in November.

Due to these changes, the Cisco CallManager, the IP Phones and the Cisco Unity can have issues with time zone.


Resolution


Review the requirements listed for the appropriate product in order to make the Cisco CallManager, the IP Phones and the Cisco Unity accept the changes to DST in 2007.


Cisco CallManager:


This issue is tracked in Cisco bug ID CSCsf07523 for the Cisco CallManager 4.x and earlier. Manually reset the time on the servers in order to workaround this issue.


In order to resolve this issue on a Cisco CallManager that runs on a Microsoft Windows version of the operating system (OS) 4.x and earlier, apply these DST fixes:

·        the database

·        the OS

·        the IP Phone load


Cisco recommends the application of the OS patch first. Then, during a separate maintenance window, apply the appropriate Engineering Special (ES) version of


Cisco CallManager, as mentioned in the First Fixed-in Version:


  • 4.3(0.41)

  • 5.1(0.9901.143)

  • 6.0(0.9411.004)

  • 4.2(1)ES38

  • 3.3(5)ES56

  • 5.1(1.1000.007)

  • 5.0(4.2123.002)

  • 4.1(3)ES89.1

  • 4.2(3)ES11.1

  • 5.1(1.2000.002)


All the Cisco CallManager versions 4.x and earlier run on the Cisco IP Telephony (IPT) operating system, which is the Cisco version of the Windows 2000 build.


Therefore, in order to obtain the 2007 DST changes required for the operating system, apply either of these versions, which are available from Cisco Downloads:


·        OS 2000.4.4a(sr4)

·        OS 2000.4.3a(sr9)

·        OS 2000.4.2(sr16)


Refer to Field Notice: FN - 62669 - U.S. Daylight Savings Time Policy Changes Effective March 2007 - for Cisco CallManager  and Cisco Bug Id : CSCsh20360 for more information.


Cisco Third Generation IP Phones (7941/7961/7971):


This issue is documented in Cisco bug ID CSCse47164 for the Cisco third generation IP Phones, which require a Sun Java Patch in order to accept the U.S. DST changes. These IP Phone loads incorporate the DST fix for the Cisco third generation IP Phones:


·        8.2(1)

·        8.2(2)

·        8.3(1)

·        8.0(4) ES06 (00.01)


The DST fixes for the correct Cisco CallManager version must also be applied in order to support this change.


Cisco Third Generation IP Phones (7970/7971/7961/7941/7911/7906):


The time change for Daylight Savings time may not take affect automatically for a third-generation IP Phone that runs SCCP or SIP loads older than 8.2(2).

This issue is documented in Cisco bug ID CSCsh12444.

These are the third-generation IP Phones:

  • 7970

  • 7971

  • 7961

  • 7941

  • 7911

  • 7906

After the phone is upgraded to 8.2(1) or 8.0(4)SR3 in order to get the fix for the 2007 DST changes, this issue can appear.

In order to workaround this issue, reset the IP Phone from the Cisco CallManager Administration (CCMAdmin) in order for the phone to obtain the correct time. A power cycle of the phone does not fix the time.

The conditions required for the phone to update the time zone are the root cause of the bug. Without this fix, the only time the phone updates the time zone is if the clock drifts more than 10 seconds off of the NTP server time.

If the phone is power cycled after it has the correct time, the time returns to the wrong time, off by an hour.

The fix for this bug is available in these phone loads and later:

  • 8.2(1)ES5
  • 8.2(2)


Media Convergence Servers (MCSs):


This issue is documented in Cisco bug ID CSCsf07541 and CSCsh20360 for the MCS. These Cisco MCS OS versions include the Microsoft Hotfix KB924840 for the Windows 2000 based operating systems:


·        2000.4.2(sr16)

·        2000.4.3a(sr9)

·        2000.4.4a(sr4)


These versions are available from Cisco Downloads. Upgrade to one of those OS versions in order to get the fix.


Cisco Unity/Cisco Unity Bridge:


The potential problem with the Cisco Unity relates to Inbox timestamps, which can be incorrect by an hour for three weeks in the spring and one week in the fall for the year of 2007 and beyond. In other words, the Cisco Unity voicemail timestamps can be off by one hour during the periods when the new DST begins or ends. This can impact any event correlation activities that are performed as a part of normal operations, troubleshooting, or monitoring.


If the patches to Windows and the Cisco Unity are not applied, adjust the time manually through the Windows operating system.


In order to resolve this issue, apply these fixes and patches:


The features and version that are used dictate the specific patches needed. Some systems can require patches to the operating system, the Java Runtime Engine and a specific Cisco Unity Engineering Special (ES). Other systems only require the operating system patch. A single downloadable file, available from Cisco Downloads, bundles all the patches necessary for the Cisco Unity and the Cisco Unity Bridge. Complete these steps in order to resolve the timestamp issue:


  1. Download the ZIP file.

  2. Extract the contents into a folder on the Cisco Unity or Cisco Unity Bridge system.

  3. Locate and open the ReadMe.txt file within the folder that the ZIP extraction created.

  4. Complete the instructions provided in the ReadME.txt file.


Refer to Cisco bug ID CSCsh63361 for more information.


This table lists the Cisco Unity and Cisco Unity Bridge versions to which each patch applies. If a version of the Cisco Unity is not listed, no patch is necessary.



Patch Name:

Unity_DST_Patches.zip

Cisco Unity

Required Patches

Cisco Unity Versions Affected

Windows 2000 SP4

All

Windows 2003 SP1

All

Java Runtime Engine

4.0(1) and later

Cisco Unity Inbox

4.2(1)

4.1(1) if ES39 is previously installed

4.0(5) if ES34 is previously installed

Cisco Unity Bridge

Required Patch

Cisco Unity Bridge Version Affected

Windows 2000 SP4

All

Windows 2003 SP1

All



Refer to these documents for more information:


Version history
Revision #:
1 of 1
Last update:
‎06-22-2009 04:07 PM
Updated by:
 
Labels (1)
Comments
New Member

How can 7911 phones be successfully upgraded to work with a SIP,  IPBX?

I need help in this regard, because I am working to figure out how to interface these phones with the 3CX Phone System, which is an IPBX.

Blue

Hi

Please post your query in the forum under Discussion .

Home ----> NetPro ----> Collaboration, Voice and Video  ---->IP Telephony

this is not the correct place to ask query

Regards

Ronak Patel