Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

IP phone cannot get ip address from CUCM 7 DHCP

I have configured DCHP function on CUCM 7.0.

And also configured Data Vlan, Voice Vlan and Server Vlan on PoE switch 3560.

Althought, ip phone cannot get ip address from CUCM and showing "Configuring IP....." on phone screen.

Anyone can help my issue.

Thanks.

Comments
New Member

Have you checked the Vlans?

Tagged for Voice and untagged for data...

I am new in this world but maybe that is the problem...

Hope that helps...

kmm
New Member

I did not add that command. Could you plase provide me some sample configuration about Vlans.

Thanks a lot.

New Member

Where is the dhcp server? is it on a diferent Vlan than the phones vlan?

kmm
New Member

Configured CUCM server as DHCP. Yes. it is different Vlan.

Callmanager server vlan is 200 and phone vlan is 30.

New Member

Is it not better to have them on the same Vlan?

If not, have you tried to add it as dhcp helper?

kmm
New Member

here is my sketch connection for testing before implemented to production.

Callmanager--------Switch 3560A---------Switch 3560B------------ip phone

Switch3560B

interface FastEthernet0/23

desscription connection to Switch3560A
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,20,30,130,200
switchport mode dynamic desirable

-------------------------------------------------------------
3 ip phones connected to following ports on switch 3560B

interface FastEthernet0/8
switchport access vlan 200
switchport voice vlan 30
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 200
switchport voice vlan 30
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast
!
interface FastEthernet0/10
switchport access vlan 200
switchport voice vlan 30
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast

interface Vlan1
no ip address
shutdown
!
interface Vlan30
ip address 10.10.30.2 255.255.255.0
!
!
interface Vlan230
ip address 10.10.230.2 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.200.1

------------------------------------------------------------------

Switch 3560A for Server line connection

interface Vlan10               
                    
ip address 10.10.200.2 255.255.255.0                                    
!
interface Vlan20               
no ip address             
!
interface Vlan40
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.200.1
ip http server
!

--------------------------------------------------------

Router 2811 which connected to Switch3560A

interface FastEthernet0/1.10                           
description ** voice server vlan **                                   
encapsulation dot1Q 10 native                             
ip address 10.10.200.1 255.255.255.0                                    
ip helper-address 10.10.200.21                              
!
interface FastEthernet0/1.20
encapsulation dot1Q 20
!
interface FastEthernet0/1.30
encapsulation dot1Q 30
ip address 10.10.30.1 255.255.255.0

Could you please check my configuration?

Thanks

New Member

not sure...

New Member

you need to add: ip helper address <ip of your cucm> to the voice vlan interface (that is, the vlan where the phones are in, not where your server is in) on your router.

hth. Ed

kmm
New Member

Changed ip helper address command to voice vlan interface would not successful. Thanks anyway.

Cisco Employee

you mean you tried adding the helper addr command here

!
interface FastEthernet0/1.30
encapsulation dot1Q 30
ip address 10.10.30.1 255.255.255.0

ip helper-address 10.10.200.21 

and it still didnt work?

Cisco Employee

Also, can you paste the config of the interface of 3560A swtich connected to the router. Have you made that as a trunk port as well?

kmm
New Member

Hello Raees,

Thanks for your advice. Still did not work.

Here is my configuration detail.

ROUTER
interface FastEthernet0/0.10
encapsulation dot1Q 10 native
ip address 10.10.200.1 255.255.255.0
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 10.10.30.1 255.255.255.0
ip helper-address 10.10.200.21
!

SW-PoE3560
interface FastEthernet0/1
description connection to CUCM7
switchport access vlan 10
mls qos trust dscp
!
interface FastEthernet0/2
description connection to server lan
switchport access vlan 10
mls qos trust dscp
!


interface FastEthernet0/20
description IP-phone connected
switchport access vlan 10
switchport mode access
switchport voice vlan 30
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust device cisco-phone
mls qos trust cos
auto qos voip cisco-phone
spanning-tree portfast

!
interface FastEthernet0/22
description VoiceVlan
switchport access vlan 10
switchport mode access
switchport voice vlan 30
spanning-tree portfast

!
interface FastEthernet0/24
description connection to Gateway
switchport trunk encapsulation dot1q
switchport mode trunk
mls qos trust dscp
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
description Server
ip address 10.10.200.2 255.255.255.0
!
interface Vlan30
ip address 10.10.30.2 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.30.1
ip http server
!

CUCM-DHCP configuration

CM > System > DHCP
Host server * =  10.10.200.21
Primary TFTP option 150 = 10.10.200.21
TFTP Server Name option 66 = 10.10.200.21

ARP Chase *  = 60 sec
IP Address Lease * = 604000
Renewal T1 time * = 320000
Rebinding T2 time * = 425000

CM > System > DHCP subnet

DHCP Server * = 10.10.200.21
Subnet IPv4 Address * = 10.10.30.1
Primary Start *   = 10.10.30.100
Primary End *    =  10.10.30.120

Primary Router IPv4 = 10.10.30.1
IPv4 Subnet Mask * = 255.255.255.0

TFTP Server Name (Option 66) = 10.10.200.21
Primary TFTP Server Name (Option 150) = 10.10.200.21

ARP Chase *  = 60 sec
IP Address Lease * = 604000
Renewal T1 time * = 320000
Rebinding T2 time * = 425000

Cisco Employee

Can you change the Subnet IPv4 Address from 10.10.30.1 to 10.10.30.0

Please connect a phone to the same switch as the CUCM server & check if that receives an IP address

kmm
New Member

Fixed it. Routing to 10.10.200.1 insted of 10.10.30.1.I did change Subnet IPv4 address to 10.10.30.0

Now ip-phone received DHCP address and registered to CUCM. Anyway, thank you for considering my issued and tried to help.

1100
Views
0
Helpful
14
Comments