Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Web Setup HTTP Error 500

 

 

Introduction

This document explains the solution for the Web setup errors

 

The information in this document is based on testing this feature on UCCE 8.5(2)

 

 

Error :-  HTTP Error 500

Resolution :-

 

Use the following steps to resolve the error “HTTP ERROR 500.0 - Internal Server Error calling LoadLibraryEx on ISAPI filter

"E:\icm\tomcat\bin\i386\isapi_redirector2.dll failed” when starting Web Setup:-

 

1. Using Windows Explorer, right-click the folder c:\icm and select properties.

 

2. Select the Security tab in the icm Properties window.

 

3. Verify the permissions for the Administrators role is set to Full Control (all items checked under Allow). If the permissions are not  set correctly then click the Edit button and modify the permissions.

 

4. Verify the permissions for the Users  role has a check mark under Allow for the following:-

 

• Read & Execute

 

• List folder contents

 

• Read

 

• Special permission

 

5. If the permissions are not set correctly then click the Edit button and modify the permissions.

 

 

 

Error:-HTTP Error 404.0 - Not Found.The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

Resolution :-

 

Use the following steps to resolve the error HTTP Error 404.0 - Not Found.The resource you are looking for has been removed, had its name changed, or is temporarily unavailable"

 

 

1.)    Open Internet Information Service Manager.

 

 

2.)    Navigate Sites->Default Web Site.

 

 

3.)    Click on ISAPI filters. Check the number of filters configured.

 

 

There should be only one filter -> tomcat. Make sure the filter is pointing to the executable isapi_redirector2.dll from directory <instalDrive>:\icm\tomcat\bin\i386.

 

If there are no filters, please create one with name tomcat and select the executable isapi_redirector2 from location <instalDrive>:\icm\tomcat\bin\i386.

 

 

4.)    Restart Apache , IIS and WWW services.

Comments
Cisco Employee

Thank you for this post. I had the same HTTP 500 error in a UCCE 9.0 fresh install (as well as after upgrading to 9.0.4) on Windows Server 2008 R2. The only difference to the error message is that the isapi file name has changed: 

"E:\icm\tomcat\bin\i386\isapi_redirect.dll failed

I tried the resolutions above, but they did not work for me. My resolution for UCCE 9.0 and 9.0.4 was to install the Web Server (IIS) Role into Windows Server first, before running the CCE install setup. Below are screenshots of the Web Server (IIS) Role Services I used, that resulted in a successful and working PG:

1912
Views
5
Helpful
1
Comments