Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

When upgrading Cisco CallManager, how to determine the version of Cisco CallManager TAPI so that compatibility with ARC ACD is ensured

Core Issue

ARC Automatic Call Distribution (ACD) is used in this environment, and the Cisco CallManager is upgraded from 3.1 to 3.3. The Telephony Application Programming Interface (TAPI) must be upgraded as well. Therefore, a TAPI version that is compatible with ARC and Cisco CallManager is required. Ideally, using the existing version of TAPI is best if it is compatible with Cisco CallManager 3.3(2). But knowing how often software tents must be updated and improved, the chances of the existing TAPI working with both 3.3, 3.1 and ARC are unlikely.

Resolution

According to the Compatibility Matrix, you can upgrade from 3.1.4b to 3.3.2. The Java Telephony Application Programming Interface (JTAPI) version is 1.4(2). This is the one that you should use. Contact ARC to see if they support this version. If you install the Cisco CallManager, you can get the JTAPI from the Plug-ins page.

Version history
Revision #:
1 of 1
Last update:
‎06-22-2009 06:13 PM
Updated by:
 
Labels (1)