Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

With Cisco CallManager 4.x, the outbound calls made through an FXO port on the H.323 Cisco IOS gateway to the PSTN occasionally drop

Core Issue

This issue affects Cisco CallManager 4.x, the IP phone 7912G, and the Gateway 2851 Foreign Exchange Office (FXO) on a H.323 Cisco IOS  Software Release 12.3.11T10 gateway that is connected to the Public Switched Telephone Network Central Office (PSTN CO) and trunks through the FXO ports. 

After the installation, calls drop at a frequency of around five dropped calls per day from the IP phone to the outbound PSTN through the FXO gateway.

Resolution

In order to analyze this issue, capture the debugs on the gateway. In order to do this, issue the debug voice ccapi inout and the debug vpm signal commands.

An FXO disconnect supervision issue can cause this problem. The disconnect by the H.323 gateway can have a cause value of 86. The FXO port is configured to detect the supervisory disconnect tone from the PSTN and is instructed to disconnect the call if the far end phone disconnects first.

This is the original configuration under the FXO port:

voice class dualtone-detect-params 100
freq-max-deviation 30
cadence-variation 25

In order to resolve the issue, change the configuration to:

voice class dualtone-detect-params 100
freq-max-deviation 25
cadence-variation 10 (Unit is 10ms)

Re-configure the voice class dualtone-detect-params command in order to define the disconnect tone more accurately. This way, the FXO port does not detect the wrong tone and disconnect the call accidently.

Also, issue the shut and no shut commands on the voice ports after the changes are applied in order to make sure they take effect.

If the FXO disconnect supervision does not work properly after these changes, try to tune the parameters again. Do the Pulse Code Modulation (PCM) trace for the disconnect tone in order to investigate its pattern, which includes:

  • frequency

  • power

  • cadence

If the debug vpm signal command outputs NO_TIP_GROUND that means the polarity of the RJ-11 cables is mismatched. Change the polarity and use a 2-pair cable instead of 4-wire cables.

Refer to FXO Answer and Disconnect Supervision for more information.

Version history
Revision #:
1 of 1
Last update:
‎06-22-2009 04:46 PM
Updated by:
 
Labels (1)