Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Agent Desktop not connecting to CTIOS Server

Currently the Session object on my workstation will not connect to the CTIOS Server. I've checked the values for the CtiOsA, CtiOsB, PortA and PortB values and they are correct. They match what is currently working on another workstation.

CtiOsA = someIP_A

CtiOsB = someIP_B

PortA = 42028

PortB = 42028

I'm able to ping the IP addresses successfully, so I've got network connectivity to those servers. I was curious about what the Agent Desktop code might be getting as an error message so I had it dump the value of the pIArgument collection to a logfile on the OnConnectionFail event for the Session object. Here's the result of that dump.

Arguments contains 4 Args

EventTime:19058813

ReasonCode:3

FailedServer:localhost

ErrorMessage:CCtiOsSession: Cannot connect to a server.

I have no idea what to do with the Reason Code and cannot find any documentation on it. The interesting thing to me is that the failed server comes up as localhost instead of one of the CTIOS servers. I've looked through the CTI OS Troubleshooting guide but it hasn't helped me much for this issue. Does anyone happen to know what might be the issue here? Thanks for your time and attention.

Andrew

5 REPLIES
Cisco Employee

Re: Agent Desktop not connecting to CTIOS Server

Hi Andrew,

the problem might reside in the credential or the OS, what are your version of CTIOS and OS?

Try this note to confirm the login is properly done:

http://www.cisco.com/en/US/products/sw/custcosw/ps1001/products_tech_note09186a0080094b14.shtml

Regards,

Riccardo

Green

Re: Agent Desktop not connecting to CTIOS Server

I have seen this problem before - today in fact. I have CAD installed and wanted to check something in CTIOS, so I installed that too and the 7.2(4) patch (to match the server). I configured the side A and side B hosts during setup, but the CTIOS Client would not start. The registry showed that my hosts were there - but the trace talked about localhost.

I ran Program Files\Cisco Systems\CTIOS Client\Setup.exe and the hosts were there as I expected. But after that, it worked.

Do not ask me why! ;-)

Regards,

Geoff

Re: Agent Desktop not connecting to CTIOS Server

Guys,

I just uninstalled and reinstalled CAD, relicensed it. Now the clients are getting a cannot connect to CTIOS server? Any ideas?

Chad

Green

Re: Agent Desktop not connecting to CTIOS Server

Chad, I always install a CTIOS Agent (and Supervisor) on one of the desktops so I can test apart from CAD.

Regards,

Geoff

Re: Agent Desktop not connecting to CTIOS Server

I just uninstalled CTIOS, reinstalled it, upgraded it to 7.2(1) and worked no probs, not sure what happened...

Thanks as always!

Chad

1040
Views
0
Helpful
5
Replies
CreatePlease to create content