Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Agent Greeting / Agent Recording error

Agent greeting enabled

DailNumber created for CM routing client as PlayAgentGreeting, RecordAgentGreeting

CallTypes created as same

Script mapped.

 

it is failed at Ext VRU Script node in RecordGreeting script.

 

Not sure about any other configuration is request like (call manager route pattern, cvp ops console change or any other script changes.

 

I am getting the error message Error [10170] Routing error while recording Agent Greeting

 

with Regards,

Manivannan

1 ACCEPTED SOLUTION

Accepted Solutions

i may not be able to give

i may not be able to give screenshot as i am away from system.

the fow for greeting will be similar to warm transfer/consult transfer for done by call transfer to queue for CVP.

 

let me try to explain bit:

1. agent pim requests playagentgreeting Dialed Number and performs route request.

2. router runs routing script and encounters Send to VRU node.(it is always best practice to use send to VRU before performing any IVR Treatment with CVP), Run External Script by default has this mechanism internally but still good to use.

 

3.router sends VRU label to PG (this will be configured under network VRU explorer, and it will be for your CM peripheral), and label will be always appended with corr id.

4.this label has to reach CVP to successfully complete the operation, so you will need route pattern that covers label+corr id.

5.label reaches CVP and CVP performs route request with this label to router,

by seeing corr id router co-relates the call and resumes routing script.

6. now one more VRU label(label+corrid) will be sent to CVP as per the configuration, and this will be CVP RC.

7. CVP will match label to one of the VXML VG.

8.VXM VG will match Dial-peer and runs bootstrap application.

9.bootstrap application makes HTTP request to IVR service of the same call server, this will correlate call from CVP side.

9. roue request will be submitted to router,seeing corr id router co-relates the call and resumes routing script.

10. now you can perform any ivr treatment to caller, like run ext script etc.

 

regards

chintan

9 REPLIES

Hi,Are you using the out of

Hi,

Are you using the out of box record AG script? if yes please insert send to vru node and see if it passes successfully.

i used my own customize Record AG script, it will ftp file to pre defined Path.

and when it comes to play. i fetch same greeting.

 

 

regards

Chintan

Chintan,I am not using any

Chintan,

I am not using any third party tool, what ever mentioned in the cisco document i am following.

 

I have tried to put send to vru node but it fails at this node. I just wanted to undrestand, when agent press the playgreeting/record greeting, it is a new call initiated by Call Manager PG, How call is routed to CVP. Do we need any other configuration at call manager (route pattern) toward cvp sip trunk?

 

I have created the dialed numbers, calltype as follows

PlayGreeting --> PlayGreeting --> script

RecordGreeting --> RecordGreeting --> script

 

If possible explain with screen shots.

 

with Regards,

Manivannan

i may not be able to give

i may not be able to give screenshot as i am away from system.

the fow for greeting will be similar to warm transfer/consult transfer for done by call transfer to queue for CVP.

 

let me try to explain bit:

1. agent pim requests playagentgreeting Dialed Number and performs route request.

2. router runs routing script and encounters Send to VRU node.(it is always best practice to use send to VRU before performing any IVR Treatment with CVP), Run External Script by default has this mechanism internally but still good to use.

 

3.router sends VRU label to PG (this will be configured under network VRU explorer, and it will be for your CM peripheral), and label will be always appended with corr id.

4.this label has to reach CVP to successfully complete the operation, so you will need route pattern that covers label+corr id.

5.label reaches CVP and CVP performs route request with this label to router,

by seeing corr id router co-relates the call and resumes routing script.

6. now one more VRU label(label+corrid) will be sent to CVP as per the configuration, and this will be CVP RC.

7. CVP will match label to one of the VXML VG.

8.VXM VG will match Dial-peer and runs bootstrap application.

9.bootstrap application makes HTTP request to IVR service of the same call server, this will correlate call from CVP side.

9. roue request will be submitted to router,seeing corr id router co-relates the call and resumes routing script.

10. now you can perform any ivr treatment to caller, like run ext script etc.

 

regards

chintan

Chintan, thanks for

Chintan,

 

thanks for explanation it is very clear. I got stuck in below config

router sends VRU label to PG (this will be configured under network VRU explorer, and it will be for your CM peripheral), and label will be always appended with corr id.

Now it is passing the send to vru node and playing the menu. but now it is failured at 

Run Ext. Script node (Audium, GS,Server,V), i am using the default media server (cvpcall server+vxmlserver+mediaserver)

when i checked the activity log of RecordAgentGreeting vxml application nothing is there, that means it is not hitting the application.

I am suspecting that what ever variables ECC created recently is not taken effect. becuase i found the following error in cvp call server logs

 

CONNECT message, sending EVT RPT back to ICM -  >>HEADERS: (JMSType)=MsgBus:CONNECT (JMSDestination)=Topic(CVP.ICM.CC.RESP.SYS_SIP2) (JMSTimestamp)=1402823524903 (ServerID)=WIN-PBC34IB91T5.SYS_ICM2:ICM:ICM2:WIN-PBC34IB91T5.MsgBus002 >>BODY: callguid=0B527E56F3A411E3987E78DA6E493500 RouterCallKey=1113 floatingvars=>>HEADERS: (JMSType)=MsgBus:FLOATINGVARS >>BODY: callvars=[, , , , , , , , , ] user.microapp.app_media_lib=app user.microapp.media_server=media user.media.id=0B527E56F3A411E3987E78DA6E493500 user.microapp.FromExtVXML=[null, null, null, null] user.microapp.ToExtVXML=[null, null, null, null, null] user.microapp.locale=en-us user.microapp.input_type=D  >>STATE: isTabular=false isWriteable=true cursor=-1 dnis=8015 correlationid=26711 timezone=Asia/Riyadh RouterCallKeySequenceNumber=0 version=CVP_10_0 RouterCallKeyDay=151010 labeltype=-1 label=8111126711 localOffset=180 calllegid=B527E56-F3A411E3-90EDEE36-70AFD42F  >>STATE: isTabular=false isWriteable=false cursor=-1 [id:5005] 

 

kindly guide me. how to proceed further.

 

with Regards,

Manivannan

 

 

Chintan, Above problem also

Chintan,

 

Above problem also resolved but last i got stuck up in 

Agent Greeting Recording Fails - Check Required Information,exit,no ftp server

 

I hearing no ftp sever has been indicated message.

I have configured everything as per Cisco doc. but still it is giving error,  i have cross verified with my Firefox browser it is working fine. Is there any other way to cross check the FTP configuration. 

 

with Regards,

Manivannan

You will need FTP enabled

You will need FTP enabled media server.

 

first you have to enable windows ftp service along with IIS web server,

the root directory for both will should be same. 

test ftp service by this url: ftp://<Media-server IP>/ in windows explorer. you should get some content. most probably content of root directory of FTP server.

 

and after that add media server in your Ops console, and provide ftp credential and configuration.you should be able to perform test sign in successfully.

 

 

please read "Media Server Configuration Requirements"

at:

http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/cust_contact/contact_center/ipcc_enterprise/ipccenterprise8_5_1/configuration/guide/agwa85fg.pdf

 

regards

Chintan

 

hi chintan, I did exactly

hi chintan,

 

I did exactly what they mentioned in the document, i am able to browse from firefox

ftp://ipaddress/ but i am not able to do it in IE. i will try it in windows explorer again today. in cvp ops i did the test sign in it is passed, i am using anonymous access.

feels some sort of restart or small config missed.

 

with regards,

 Manivannan

Hi,For all the people who are

Hi,

For all the people who are facing this issue ... Remember you always have to deploy the Media Server on your OPS Console after adding the FTP Details.

Most of the people do this,but you can simulate this problem and test,Just don't deploy the Media Server after adding the FTP details and you will get an error that "No FTP Server ........ 

So the Magic is deploy the Media Server on OPs Console!!!

 

Cheers!!!!

 

 

this is most probably you

this is most probably you have configured ECC variables and did not bounce PG to load them.

can be resolved by exit_opc.

659
Views
5
Helpful
9
Replies
CreatePlease to create content