Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

agent is unable to login

 

Hello,

We have issue with agent logging in.

Trying to integrate our UCCE (Staging) with seibel  with CTI server. We have installed the connector verified through the config .... all is intact as par the recommended guidelines of seibel vendor. 

 

As well as Services are also active from UCCE end. Agent instrument is also participating in the Jtapi application user.

When attempted to login with the CTI  tool , we are getting error : " Error: Login could not be performed- Possible cause are invalid instrument; Media termination Problem or other CM issue." .

Verified through the procmon : enclosed the snapshot...

not sure if i need to upgrage the CUCM to overcome this issue.

Any thoughts would be appreciated.

CUCM : 8.5.1.1000

Agent CTI toolkit: 8.5.7

Cheers,

2 ACCEPTED SOLUTIONS

Accepted Solutions

Is the agent extension

Is the agent extension included in an Extension Range in the Agent Targeting Rule List in UCCE?

-Jameson

-Jameson

hi, there is a makecall

hi,

 

there is a makecall utility comes with JTAPI when you install it on your machine for integration.

its located under,

C:\Program Files\JTAPITools\makecall (probably on your PG server)

 

use that utility to verify your JTAPI is working correctly.

 

go to command promp

move to that folderc (CD C:\Program Files\JTAPITools\makecall)

 

and run

 

java makecall <origin> <login> <password> <delay> <origin extension> <destination Extension>

 

exmaple 

 

java makecall 192.168.50.5 pg1user pg1user 1000 23006 25000

 

where 

192.168.50.5 is CUCM

pg1user, pg1user is username and password

1000 is delay in millisecond

23006 is the extension monitored by jtapi

and 25000 is extension i am trying to call

 

if this works then you JTAPI is working correct, you may possibly look at sieble.

if doesnt , then please try to reasociate/reset device.

 

regards

Chintan

6 REPLIES
Community Member

 seeing the message from jgw

 

seeing the message from jgw log  " 2424com,cisco.jtapi.invalidargumentExceptionImpl: Address 2424 is not in the provider's domain" .

 

Is this issue due to CTI manager??

hi, there is a makecall

hi,

 

there is a makecall utility comes with JTAPI when you install it on your machine for integration.

its located under,

C:\Program Files\JTAPITools\makecall (probably on your PG server)

 

use that utility to verify your JTAPI is working correctly.

 

go to command promp

move to that folderc (CD C:\Program Files\JTAPITools\makecall)

 

and run

 

java makecall <origin> <login> <password> <delay> <origin extension> <destination Extension>

 

exmaple 

 

java makecall 192.168.50.5 pg1user pg1user 1000 23006 25000

 

where 

192.168.50.5 is CUCM

pg1user, pg1user is username and password

1000 is delay in millisecond

23006 is the extension monitored by jtapi

and 25000 is extension i am trying to call

 

if this works then you JTAPI is working correct, you may possibly look at sieble.

if doesnt , then please try to reasociate/reset device.

 

regards

Chintan

Community Member

 Thanks chintan ... will try

 

Thanks chintan ... will try this ...

@Jameson  -  We have device taget defined.. thanks

Just a quick ccheck .... Can a standalone CUCM node is allowed to participate in jtapi-pim connection with two different PG's??? my answer is Yes.... but just wanna be sure.

ie: two different PG server referencing to same single CUCM node for PIM.

Cheers

In LAB environment,Yes its

In LAB environment,

Yes its possible.

 

in production:

i dont have answer on cisco's support on this. document says max of 5 are allowed for CUCM 8.6 or later and max of 3 for previous release.

basically if you have only one subscriber running CTI manager, you will loose redundacy from CUCM side. if your CTI is down, all the PGs will be inactive.

 

but coming to your question:

we have this configuration in place for one site, its cluster of 6 subscriber and 1 pub.

and 4 PGs are connected to them. and for one subsciber pair 2 PG connection are configured.

 

regards

Chintan

 

~please rate all helpful posts

Is the agent extension

Is the agent extension included in an Extension Range in the Agent Targeting Rule List in UCCE?

-Jameson

-Jameson
Community Member

Thanks for all the valuable

Thanks for all the valuable inputs ... it was jtapi issue. Though the CTI Manager in cucm had problem PIM was stilll showing as active (even after recycle of services).

Hint to Rest all: RTMT is also useful to find the 'jtapi'applicate user route points to validate  CTI controlled RP's.

Hence we have redirected to another node...& all working fine.

 

149
Views
0
Helpful
6
Replies
CreatePlease to create content