Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Agent Missing from Supervisor Desktop

I have recently upgraded our Call Center v3.5 to CCX 7.0(1).  The processes of adding an agent are not quite the same. I seem to have a problem getting the agents to show up in the Cisco Supervisor Desktop Application.   The agents seem to be able to get into the queue, and are presented calls.  I can see him in the Real Time Reporting - Report - Resource Contact Center Express Stats, just not in the Supervisor Desktop.

Does anyone have any suggestions of where to look first?

Thank you,

Debbie Olah

12 REPLIES
VIP Super Bronze

Re: Agent Missing from Supervisor Desktop

You need to assign the agent (and supervisor) to the appropriate team. This is done under the RmCm subsystem.

Community Member

Re: Agent Missing from Supervisor Desktop

Jonathan,

Thanks for responding, but I have already done that.  He's listed under the Resources, and is in a Resource Group and a Team, has an extension and the phone is associated with rm_jtapi.

Like I said, I can see him in the RealTime Monitoring, but not in the Supervisor Desktop.

Debbie

VIP Super Bronze

Re: Agent Missing from Supervisor Desktop

If the supervisor and agent are assigned to the same team and you are still not seeing them in CSD, then this is likely a firewall problem.

Check to ensure the appropriate ports can be reached from the CCX server, agent, and supervisor PCs:

https://supportforums.cisco.com/message/3047254#3047254

Re: Agent Missing from Supervisor Desktop

Ah, that is a good point too (+5 to you Mr. Shulenberg)... I had a PC-based FW issue not too long ago, though the Supervisor desktop couldn't see any stats if I recall correctly. In either case, it is a good check as the ports used by CSD have definitely changed.

Also check that you selected the team and also see if agents are displayed when you select the CSQ in the supervisor desktop.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Community Member

Re: Agent Missing from Supervisor Desktop

http://supportforums.cisco.com/thread/2010018

not sure if this will help............but ya never know.

Re: Agent Missing from Supervisor Desktop

Well, if all agents are on the same team as the supervisor then I have to ask if you selected the team from the drop down list at the top of the Supervisor desktop. Maybe an erroneous question, but given that you made a significant jump in revisions (and I am not familiar with 3.5) it may be worth a quick check.

HTH.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

Community Member

Re: Agent Missing from Supervisor Desktop

Thank you both for responding, but this has been resolved. 

I think it was resolved by adding the the Standard CCM End Users, Standard CTI Allow Call Park Monitoring, and Standard CTI Enabled groups to his ID.   When I did this yesterday, I still couldn't see him, but this morning when he logged in, I could see him in the Supervisor Desktop.  I think it was the act of logging out and back in again after the group permissions were applied is what fixed this issue.

Thank you

Debbie

Re: Agent Missing from Supervisor Desktop

I am glad it is resolved for you but the suggested resolution doesn't make sense to me given other data points earlier in this thread. Jonathan, thoughts?

Maybe it doesn't matter, but I am curious.

Regards,

Bill

HTH -Bill (b) http://ucguerrilla.com (t) @ucguerrilla

Please remember to rate helpful responses and identify

VIP Super Bronze

Re: Agent Missing from Supervisor Desktop

I'm pretty sure that the CCX documentation states that both the end user and the rmcm application user require CTI control/privliges over the device. I'm a little surprised as well that this was the symptom of that misconfiguration for the agent's lack of CTI control.

Community Member

Re: Agent Missing from Supervisor Desktop

I'm sure that the rmcm application user has the right permissions, because I have other users that were working just fine.  This was the first user I added since we upgraded and this little piece of the instructions was missing.  It was the only thing that I remember changing yesterday and truly thought it didn't work.  Today I was going to work on firewall and ports, but when I checked on him in the Supervisor Desktop, he was there.

Super Bronze

Re: Agent Missing from Supervisor Desktop

Hi

In my experience, agents don't need adding to any of the groups in particular. They certainly don't need the CTI-related ones (it's all proxied via the RM or telecaster users).

Usually where people need to be a member of 'End Users' for a given app it shows up as problems with initial log in (as do CTI problems with UCCX) rather than the original issue described here with invisible agents in CSD. I would have agents in that group, but I'm not sure they specifically need to be.

Agents need associating to the handset or EM profile, but really only so that the IPCC Extension drop down can then be populated using the linked phone/profile info.

Typically invisible agents is one of two things:

1) Network/firewall problems

2) 'Team' misconfig

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
Community Member

Re: Agent Missing from Supervisor Desktop

As a note, I have seen this same symptom resolved by reinstalling the CAD on the workstion (after verifying the team config and verifying that it is not a firewall issue by telnetting  to the ports on the UCCX server).

Tom

1909
Views
5
Helpful
12
Replies
CreatePlease to create content