Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Aplication WFO don't show the files recorded

Hi,

I am using QM 8.5.2 with UCCX 8.1 and CUCM 8.6 only  for compliance recording, my problem is that the aplication desktop WFO don't show the files recorded, and I have the folow error in the QM server.

dbupload.log

ERROR QMDB2001 SQM database request failed: The DB-API returned a DB error. SQL Statement returned false..

dbproxy.log

ERROR QMDB2001 SQM database execute failed: The INSERT statement conflicted with the FOREIGN KEY constraint "EventAudit_person_FK". The conflict occurred in database "SQMDB", table "dbo.Person", column 'id'..

mana.log

INFO  MANA0000 Running polling diagnostic...

2012-08-21 11:52:31,218 INFO  MANA0002 Notification: <2012-08-17 12:20:17 QM1000 [CATASTROPHIC] Mana no pudo conectarse a Quality Management CTI Service (172.24.4.9): DESCON.>

2012-08-21 11:52:52,328 ERROR MANA2017 Failed to send notification using SMTP.

2012-08-21 11:52:52,328 INFO  MANA0000 Polling diagnostic finished.

2012-08-21 11:52:52,328 INFO  MANA0000 Next poll at 2012-08-21 12:02:30

Thanks.

Regards,

Luis

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Aplication WFO don't show the files recorded

Luis,

I am having the same error. I too am using CCX 8.52 SR3 with QM 8.52 SR1 ES06.

Did you load any SR's or ES's?

Steve

7 REPLIES

Aplication WFO don't show the files recorded

Hi Luis,

QMDB2001

Text:SQM database failed: .

Type:Error

Add’l Info:An operation to the QM database failed, and data may have been lost.

Action:Ensure that the QM database server is running.

Check the configuration settings for connecting to the database.

Confirm that the user has privileges to perform the operation.

Ensure that the user has privileges to perform the operation.

Repeatable occurrences of this, after checking all of the above, may indicate a software problem which should be reported.

Please refer the below link for more information,

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/workforce_optimization/qm_2x/reference/guide/qm26ecd-cisco.pdf

Hope it helps.

Anand

Please rate helpful posts !!

New Member

Aplication WFO don't show the files recorded

Luis,

I am having the same error. I too am using CCX 8.52 SR3 with QM 8.52 SR1 ES06.

Did you load any SR's or ES's?

Steve

New Member

Aplication WFO don't show the files recorded

Steve,

I have loaded the SR2 for QM 8.5.2.18 and  solved the issue.

Thanks.

Regards,

Luis

New Member

Aplication WFO don't show the files recorded

Thanks Anand.

Steve, have you solved the problem?

...

I have installed all again, and now, I don't have this error en the DB, but I have the same problem, I cannot see any recordings in the  WFO,  however in the QM server.. common  files/QM/recordings/audio, there are the files .spx.

Regards,

Luis

New Member

Aplication WFO don't show the files recorded

Hi All,

I have the same problem in QM 8.5_SR2 and SQL 2008 R2 SP2 , Any solution ?

I guess there is something worng in the QM to DB communication but I can not figure out the problem

Regards

Remon

New Member

Aplication WFO don't show the files recorded

Luis/Steve - either of you figure this out?  Running into the same problem with the same versions and same error messages.  Everything was working for about a week and now I can't search for recorded files past a certain date.

Think the only thing that was change was the Route Pattern extension for the SIP trunk.

Thanks,

Dan

New Member

Aplication WFO don't show the files recorded

Dan,

Turns out my original problem was patience. Since I was running Quality Workflow (not Archive) the system waits till the End of the Day (as configured in the Workflow) to upload and show any of recordings, even though I have 100% checked. This confused me, but I was told this is normal. The next day I saw recordigns up to End of Day from the previous.

However, weeks later, the supervisors noticed that recordings stopped showing up one morning. It took a reboot of the QM server to get the recordings to start taking again. This is currently open as a TAC case. Strange thing about this is that there were NO recordings on the agent workstations during this time. Nothing in the recordings or the staging folder. I would have thought that if the server stopped taking uploads that they would have loaded up in staging folder on the agent's computer.

2078
Views
0
Helpful
7
Replies