Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Bronze

Application Notification Failed

When trying to add a script application, I get the message "Application Notification Failed on the following servers" (hostnames of primary and failover IPCC servers).

The Application does get created, but no script is selected so it doesn't work. Also, the Application Subsystem goes in to Partial Service.

I know this isn't a script problem, since I tried it with aa.aef and a completely blank script I wrote.

Anybody seen this before?

4 REPLIES
Bronze

Re: Application Notification Failed

Main error I'm seeing in syslog when trying to add an application:

%MADM-EXECUTOR_MGR-4-MISSING_RESOURCE: Missing thread priority resource; Facility=MADM; Sub-Facility=ADM_CFG; Executor id=ADM_CFG_CLUSTERMUTEX; Exception=java.util.MissingResourceException: Can't find resource

TAC seems baffled so far.

New Member

Re: Application Notification Failed

This is because your script is trying to call some resources not available in your IPCC servers.

I had the same problem before. I tested my script in my Lab IPCC cluster and all went well. When I try to create the application in production IPCC Cluster, it generated the error as you mensioned. The problem was that the script was trying to call a subflow script that I did not upload into production Cluster. If you look at the log closely, you will find that when you get errors, other failed log appears at the same time. Those failed log will give you a clue what resources are missing.

Hope this helps.

Bronze

Re: Application Notification Failed

That was TAC's idea, but I created a script that simply answered and hung up the call and had the same result.

When you say "other failed log", which logs specifically? MIRV? JTAPI?

New Member

Re: Application Notification Failed

Here is an example:

When create an application in CRS, got error: Application Notification Failed on Following Servers.

I searched the log. Here the location of the log: COntral Centre > Server Name > CRS Administration. Logfile name I used: Cisco002MADM09.log.

Inside this log, Search "Application notification failed? String. The problem happened at Jul 18 09:44:15.876 EST. Around this time, I can also see a few other errors. One of them is:

invalid script: xxxx_IVR_Enhanced.aef; error in Play Prompt (--Triggering Contact--, Invalid_Anounce) is: Play Prompt: Invalid Prompt: com.cisco.expression.ExpressionLexicalException: invalid identifier: Invalid_Anounce (line: 1, col: 1); nested exception is:

166580: Jul 18 09:44:15.876 EST %MADM-ADM_CFG-3-EXCEPTION: com.cisco.expression.ExpressionLexicalException: invalid identifier: Invalid_Anounce (line: 1, col: 1)

Here it says the error was related to the Prompt (invalid identifier: Invalid_Anounce).

When I look at the script again, found that the Variable name was changed, but the Play Prompt step was still pointing to the old Variable.

Hope this helps.

595
Views
0
Helpful
4
Replies
CreatePlease login to create content