Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CAD email ready/not ready disabled.

Hi Folks,

In the process of setting up email contact capability and have successfully configured CCX to integrate with Exchange.  I can see the email account and that it has automatically created a folder for my test CSQ and emails are coming in and being routed to the CSQ folder.  They aren't however being routed then to the assignments subfolders, I believe because the test agents can't set themselves to email ready, because Cisco Agent Desktop shows that the email ready/not ready buttons are greyed out.  What have I missed having followed the CAD and CCX guides?

cad.png

Everyone's tags (4)
11 REPLIES

CAD email ready/not ready disabled.

Hi Geordie, do you create the CSQ as an email CSQ and asign it to the agent?

Regards,

Gabriel.

New Member

CAD email ready/not ready disabled.

Hi Gabriel,

Yes I did.  We can tell this is working correctly because otherwise the mailbox wouldn't be receiving email and routing it into the appropriate CSQ sub folder..

New Member

Re: CAD email ready/not ready disabled.

Ok I think I know what's wrong but not how to fix it.  Wireshark convo output between CAD and Exchange;

* OK The Microsoft Exchange IMAP4 service is ready.

A0 CAPABILITY

* CAPABILITY IMAP4 IMAP4rev1 AUTH=NTLM AUTH=GSSAPI AUTH=PLAIN STARTTLS UIDPLUS CHILDREN IDLE NAMESPACE LITERAL+

A0 OK CAPABILITY compleNted.

A1 AUTHENTICATE PLAIN

+

AvNpc2NvQWdlbnREZdNrdG9wSW1hAH1273FyQ0Y1

A1 NO AUTHENTICATE failed.

A2 LOGOUT

* BYE Microsoft Exchange Server 2010 IMAP4 server signing off.

A2 OK LOGOUT completed.

So CAD is acting as an IMAP client (expected), asking to authenticate in plain text (expected), then sending an encrypted password (wut).

CAD email ready/not ready disabled.

Hi, maybe this links can help you:

https://supportforums.cisco.com/thread/2110539

https://supportforums.cisco.com/thread/2083729

What UCCX version are you using?

New Member

Re: CAD email ready/not ready disabled.

None of the existing suggestions on this forum helped, I checked before I posted.  It's UCCX 9.

New Member

Re: CAD email ready/not ready disabled.

An initial review would suggest the following possible causes:

-          invalid username/password entered in.

-          the connection to exchange is on a port that allows a certain type of connection but the credentials were provided in a different format. The install guide states what the forms of the credentials must be depending on the connection type. e.g. for NTLM, provided login must be domain\username, etc.

Beyond that, you'll want to work this through with TAC if you aren't already.

Regards,

Tom

New Member

Re: CAD email ready/not ready disabled.

We had a same problem but were able to resolve it after a long time. Hope you have premimum license follow the instruction for email setup guide. also user should assigned to email csq with proper skills and competense. Also a correct version of Java.

New Member
New Member

CAD email ready/not ready disabled.

I was wondering if have resolve this issue ?

New Member

CAD email ready/not ready disabled.

This got resolved but I couldn't tell you how.  I had to rip out all the configuration and go again and whatever was misconfigured the first time is now correct.

New Member

Hello, I Have this problem,

Hello,

 

I Have this problem, but we don´t have Exchange. We have Apple Mavericks OSX Server 10.9 with IMAP and SMTP.

From Desktop Administrator i can connect with the server usign IMAP and SMTP, but  the system  can´t assign it to agents. All emails remain in CSQ folder and email buttons in Agent Desktop Interface are disable.

Any idea about this ?

I know that this works good with exchange but my customer don´t have this software and licences.

Thanks.

 

 

 

1015
Views
0
Helpful
11
Replies
CreatePlease to create content