Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CAD login fails for some agents, other agents work fine

Hello all,

until yesterday I had a full functioning IPCC Express HA Setup Ver 7.0(1)SR04_Build443 with CAD 6.6.

Since yesterday some of my CAD Clients can´t login. Other CAD Clients can logon successfull.

The error message is: "The request to log into the Cisco Unified CCX application server timed out. Please verify your system is online and try again".

At the moment it seems it has something to do with the Windows user profile or the hole PC. We recognized that sometimes the "defect" ID is working if we log on to the PC with another windows userID. But this can´t be reproduced with a 100% guarantee.

Attached are two log files from the Agent PCs. The Not_OK Agents stops after "Login to telephony server". The OK Agent continues after that with "Login to chat server" and so on.

Any Ideas?

Best regards

Manfred

1 ACCEPTED SOLUTION

Accepted Solutions

Re: CAD login fails for some agents, other agents work fine

Hello Mandred,

If your CUCM is integraded with AD, this issue could be realated with a know DDTs, this happens because "CAD client software is timing out due to not receiving a response from the UCCX server in the configured and default 10 seconds"

CSCta49259    CAD client timeout value not present in PhoneDev.cfg

Symptom:

Per MIVR logs CAD side is timing out and changes to the server-side properties did not resolve the issue.

Conditions:

UCCX 7.0(1) CAD

Workaround:

on CAD client PC
C:\Program Files\Cisco\Desktop\config, there should be a file
called PhoneDev.cfg.

add ->
[ReqTimeout]
Milliseconds=30000

save then restart the CAD client .

Also See

CSCth74824 - Slow LDAP authentication communications manager

Symptom:

LDAP authentication delayed by 10 seconds

Condition:

CUCM Appliance.

Workaround:

None

Defect opened to make following optimizations:

From the platform API logs, can see CertifiateManager.getCertificate() method being locked.

1)This method probably does not need a lock.  Like the enablePort() method, it should probably use a lock duration of 0

2)Also from IMS perspective we can do an optimization.  If LDAPS is not configured, don't initialize trust-store.

**Only 1) code changes have been done 2) code changes were done as per communication from dev team.

This issue was disccuesed in the following post a couple of days ago:

https://supportforums.cisco.com/message/3216333#3216333

Many thanks to Pablo and Anuj for the information

HTH

Please rate this post if was helpful

Walter Solano

4 REPLIES

Re: CAD login fails for some agents, other agents work fine

Hello Mandred,

If your CUCM is integraded with AD, this issue could be realated with a know DDTs, this happens because "CAD client software is timing out due to not receiving a response from the UCCX server in the configured and default 10 seconds"

CSCta49259    CAD client timeout value not present in PhoneDev.cfg

Symptom:

Per MIVR logs CAD side is timing out and changes to the server-side properties did not resolve the issue.

Conditions:

UCCX 7.0(1) CAD

Workaround:

on CAD client PC
C:\Program Files\Cisco\Desktop\config, there should be a file
called PhoneDev.cfg.

add ->
[ReqTimeout]
Milliseconds=30000

save then restart the CAD client .

Also See

CSCth74824 - Slow LDAP authentication communications manager

Symptom:

LDAP authentication delayed by 10 seconds

Condition:

CUCM Appliance.

Workaround:

None

Defect opened to make following optimizations:

From the platform API logs, can see CertifiateManager.getCertificate() method being locked.

1)This method probably does not need a lock.  Like the enablePort() method, it should probably use a lock duration of 0

2)Also from IMS perspective we can do an optimization.  If LDAPS is not configured, don't initialize trust-store.

**Only 1) code changes have been done 2) code changes were done as per communication from dev team.

This issue was disccuesed in the following post a couple of days ago:

https://supportforums.cisco.com/message/3216333#3216333

Many thanks to Pablo and Anuj for the information

HTH

Please rate this post if was helpful

Walter Solano

New Member

Re: CAD login fails for some agents, other agents work fine

Hi Walter,

thank you for your fast response.

All of our CAD´s are working now. The add of the missing timer "resolved" our problem.

Best regards

Manfred

Re: CAD login fails for some agents, other agents work fine

Is good to hear that everything is working now

New Member

CAD login fails for some agents, other agents work fine

This also solved my problem for CSCta49259

thanks everyone!

1107
Views
19
Helpful
4
Replies
CreatePlease to create content