Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Call not maturing during agent transfer

Hi,

We have implemented UCCE simplex setup in VMware environment. This is CUCM originated call. The actual flow is as follows:-

  • Initiated the call from Call Manager extension
  • Caller is able to get the IVR treatment
  • At the time of agent transfer, the caller is getting the ring tone even the call is actually delivered to the agent desktop. However we could see the realtime status of agent in ICM Script editor
  • Also in the CTI OS desktop we are getting the error message “The call has failed because the resources are not available. Please wait a moment and try again”
  • In CVP log we are getting the below error

ABNORMALLY ENDING - SIP code [200], Reason Hdr [Q.850;cause=86] Q850 Reason [86 - Call with the specified call identity is cleared], GW call using SURV TCL flag [false], NON NORMAL flag [true], USE ERROR REFER flag [true] with AGE (msecs) 84297 and Call History: 822222222297, 5417644002, [id:5004]

64064: 192.168.20.73: Feb 09 2012 16:48:20.270 +0530: %CVP_7_0_SIP-3-SIP_CALL_ERROR: CALLGUID = 61D492021000013534BBE4C03F57EBB7 LEGID = 66d93680-f33158aa-687a-2418a8c0 - [INBOUND]: Refer failed with 404 - Not Found. May be a problem with DN Routes or Gateway Dail-Peers. [id:5004]

64214: 192.168.20.73: Feb 09 2012 16:49:02.551 +0530: %CVP_7_0_SIP-3-SIP_CALL_ERROR: CALLGUID = 61D63AE010000135673DCDE93F57EBB7 LEGID = 61D63AE010000135673DCDE93F57EBB7-132878632837987 - [OUTBOUND] - DsSipInviteDialog - <sip:5417644002@192.168.24.36;transport=udp>;tag=d0e02cab-8fd5-462b-bec5-b93652ab0d3b-26901335 - 1 INVITE REJECTED WITH 503 - Service Unavailable Reason: Q.850;cause=47

[id:5004]

Note: 822222222297 - VRU label returned from the ICM where 97 is the correlation id

5417644002 – Agent extension

5004 – Call manager Peripheral ID

Expecting your suggessions

Regards,

Kohila M

4 REPLIES
Cisco Employee

Call not maturing during agent transfer

Kohila,

1. Is this a LAB setup or production one ?

2. What is the UCCE version ?

3. Which VMWare ESXi version & UCS server being used ?

4. Is CVP & CUCM also virtualized ? If yes, please post their version, ESXi version & UCS server model.

5. Does this happen only with calls initiated by CUCM endpoint or also happens to customers calling in from PSTN ?

GP

New Member

Call not maturing during agent transfer

Hi GP,

We are running this setup in Lab environment. We have not tested this scenario for PSTN calls. Given below are the version details:-

VMWare ESXi 1 - 4.0.0 (running on MCS 7845 HP server)

UCCE            - Ver 7.0

CVP              - Ver 7.0.1

VMWare ESXi 2 - 4.0.0 (running on Cisco UCS B200 M1 server)

Call Manager  - Ver 7.1.3

VXML Gateway      - Cisco 2811 ver 12.4(13r)T11

Note : Both CVP and UCCE are in VMWare ESXi 1. Callmanager is in VMWare ESXi 2

Please let me know if any other informations are required

Regards,

Kohila M

Cisco Employee

Call not maturing during agent transfer

Thanks Kohila for further details.

Please have a look at following points.

1. None of your software versions ( CUCM, CVP, UCCE ) i.e. 7.x are supported for virtualization. Please refer http://docwiki.cisco.com/wiki/Unified_Communications_Virtualization_Supported_Applications

2. Your ESXi version 4.0 is fine. http://docwiki.cisco.com/wiki/Unified_Communications_VMware_Requirements#VMware_vSphere_ESXi_Version_Support_for_Call_Processing_and_System_Management_Applications

3. Cisco supports the UC application virtualization only on Cisco UCS & not yet on MCS.

Having said above, the functionality can not be guaranteed as Cisco has not tested virtualization with above hardware & software versions.

Sorry for the bad news but thought of sharing the facts.

Hope that helps.

GP.


Pls rate helpful posts !!

New Member

Re: Call not maturing during agent transfer

Hi GP,

Thanks for your reply with the relevant details

We forgot to add a point in the first post. Actually the same setup was in working condition, but this issue is happening after we changed the Callmanager IP in CUCM PIM.

We have followed the below steps to change the CM PIM config

1.     Stopped the PG services and installed the Jtapi client which is downloaded from the new CM

2.     Executed the icmsetup.exe in PG and the services were up

3.     Configured the same IP in AW configuration Manager

4.     Changed the static route in Ops console server with new CM IP

Kindly leave your suggessions

Regards,

Kohila M

1195
Views
0
Helpful
4
Replies
CreatePlease login to create content