Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

Cannot see more than 1 CUCM server for AXL\CTI providers - new setup CUCM v9.1.2, UCCX 10.5

I'm setting up a new CUCM v9.1.2 CUCM cluster, and a single UCCX v10.5 server.  

My CUCM cluster has 4 servers, all services have started, database replication looks good.  I installed a new UCCX v10.5 server, but I can only see one CUCM server for AXL provider and CTI manager.  I verified all UCCX services have started, verified compatibility on the matrix, I'm at a loss.  I don't recall not seeing the all servers in the cluster in older versions.  It's late, I'm guessing I'm missing something.  


Any suggestions?

Everyone's tags (1)

Hi,I think I've seen


I think I've seen something similar  but with UCCX 7.0 - a long time ago. I am not sure how I solved it finally. I guess it had something to do with the CTI servers not being available. But this is certainly not your case since you wrote all of the CUCM services are up.

Is this  a new install?


New Member

Yes, this is a brand new

Yes, this is a brand new install. 

One more thing: the one CUCM

One more thing: the one CUCM you see on the list within UCCX is represented by its IP address or FQDN?

I will start up my 9.x lab and try adding another UCCX server. No promises, though.


New Member

IP Address.

IP Address.

Cisco Employee

Hi , I have seen this before

Hi ,


I have seen this before . the CUCM server which is not showing up in UCCX might not have correct DNS entry


to verify it use command " utils network host <missing call manager IP/Hostname>

use the same command on CUCM to see if call call manager can resolve UCCX hostname/IP




New Member

Thanks for the suggestion.  I

Thanks for the suggestion.  I tested from every direction, but DNS is working correctly.  I'll probably open a TAC case tomorrow and post my findings.

Cisco Employee

Yaa if DNS is working fine

Yaa if DNS is working fine the you can open TAC case might be new issue with UCCX 10.5.




Cisco Employee

Hi Jonathan,Is your CUCM 9.1

Hi Jonathan,

Is your CUCM 9.1.2 base version or SU1? This may be a compatibility issue with CUCM for all we know.

Please find the UCCX 10.5 compatibility matrix and from that only SU1 in 9.1.2 train is tested for compatibility of 10.5



New Member

I'm running 9.1(2)SU2, and

I'm running 9.1(2)SU2, and you're right, I see only 9.1(2)SU1 is listed on the compatibility Matrix for UCCX v10.5(1).


I've opened a TAC case, but I was sure I was using CUCM 9.1(2)SU1 until I double-checked.

New Member

I have the same issue , with

I have the same issue , with a fresh install of UCCX 10.5 , did you find an answer from TAC ?

New Member

I did. Originally I had CUCM

I did.


Originally I had CUCM 9.1(2)SU2.  The compatibility matrix shows only 9.1(2)SU1 being compatible with UCCX 10.5.  So TAC wouldn't help.  I then downgraded my CUCM to 9.1(2)SU1, but the problem remained - but at least TAC would help me with the issue.


The issue is a bug.  UCCX v10.5 is not fully compatible with 9.1(2).  It only sees the single CUCM pub\sub you specified during the UCCX config, but it will work.  I forget the exact details, but it has to do with the way UCCX determines a CUCM server from a Presence server.

The only way around this was:

1.  Run UCCX v10.5 attached to a single CUCM node, and wait for a bug fix

2.  Install UCCX v10.0 and use it with CUCM 9.1(2)SU1.  UCCX v10.0 is not officially compatible with CUCM 9.1(2)SU1, but TAC said "don't worry about it, even though CUCM 9.1(2)SU1 isn't officially listed, it's still part of the 9.1 family, and therefore it's supported".  This conflicted with what TAC told me earlier, causing the great hassle of down-grading CUCM from SU2 to SU1 in order to have them even take a look. /rant


I went with #2, and I'm up and running fine.

I'm curious to know how it goes for you.

New Member

I have the same issue with

I have the same issue with CCX 10.5(1) and CUCM 9.1(1a).  Do you have the bug id?

Anyone from Cisco, any word when CCX 10.5(1) SU1 will be posted?



Cisco Employee

Hey Dan,It would be the same

Hey Dan,

It would be the same issue. Defect ID which i filed is CSCup81699.

Resolved in 10.6.

10.5 SU1 was scheduled for August but due to some issues, it has been postponed to September 12 (tentative).



New Member

As Arundeep mentioned it is

As Arundeep mentioned it is bug ID CSCup81699.  Issue with UCCX: Backward Compatibility of UCCX 10.5 with CUCM 9.X.  Even though it states there is no workaround I was able to work with TAC and get this resolved with running CLI commands in the UCCX on both Primary and Secondary with the following commands:  (Open a TAC case to complete this workaround).   After I ran the CLI commands I noticed that it didn't save the listing of available CUCM unused providers in the CUCM configuration in UCCX Admin.  Hence, needing to complete the root access to keep the manual updated CUCM listings.  This resolves not having to upgrade the CUCM to 10.X yet and not downgrading UCCX 10.5.1 to 10.1.  Hope this helps somebody else.

First Step to Fix:

Set uccx provider ip axl (include the publisher and all subscribers)

Set uccx provider ip jtai (primary and secondary)

Set uccx provider ip rmcm (primary and secondary)

Utils service restart Cisco Unified CCX Engine

Utils service restart Cisco Tomcat

Second Step to Fix is for Cisco TAC to complete Root Access to both UCCX servers to upload two updated files:



New Member

This helped me out allot.

This helped me out allot.

Our system has a DNS / Cert issue. 

Pub is on

IPCC is on

Sub is on

DNS and actual structure is  -- Cluster is referencing the host names not the FQDN.  IPCC will only see the Pub so.  I manually added as above to resolve.

Now I dont know how to fix the Cert issue and if I do what will it effect?  Basically have to change the Pub and IPCC to the correct

New Member

Any additional progress on

Any additional progress on this issue? I see the bug ID there is supposed to be a patched version of 10.5 but it does not appear to be published on CCO.

~~~ Rate helpful posts Blog -
Cisco Employee

Hi,The defect is fixed in 10


The defect is fixed in 10.5.1 SU1 which is available on CCO for download. Following is the link:




New Member

I am encountering this issue

I am encountering this issue with UCCX version  integrated with CUCM version 10.5.1. I am going to try upgrading cucm to 10.5.1 SU1a....


New Member

TAC had to go in and set

TAC had to go in and set permis sins to resolve my issue. 



New Member

My issue turned to be a DNS

My issue turned to be a DNS resolution issue. UCCX want able to resolve cucm host names.  So I was not hitting a bug.

New Member

I am having this issue right

I am having this issue right now while on UCCX 10.5 SU1 so the fix doesn't appear to be in 10.5 SU1

New Member

Hello,We are having CUCM 9.1


We are having CUCM 9.1.2 + UCCX 10.5 and are facing this issue.

I was about to upgrade UCCX 10.5 to SU1.

Does upgrading UCCX to 10.5 SU1 resolve the issue?



CreatePlease to create content