Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

CCX 8.5.1 - Scripting - Problem with "Contacts Waiting" field

Hi there,

I have a pretty weird situation here.

with a Get reporting Statistic I take the Contacts waiting value within the CSQ IPCC Express report Object.

The result is place inside an integer ex : intContactsWaiting

With it I try to compare the result with a maximum value that I have manually configured.

ex:

intMaxContactsWaiting = 3

---

IF intContactsWaiting > intMaxContactsWaiting

true

Play prompt A

false

Play promt B

The problem is I can not reach the true. (PromptA) even if I have 4 contacts in the CSQ.

The weird part is, If I do a debug on the 4th call it reach the true... ONLY when I use the debug. I know it sounds weird and I did'nt find any explaination on that. As soon as I use the debug for the third call, the script seems to be fine, when I look at the value of all variable they are well populated.

3 REPLIES

CCX 8.5.1 - Scripting - Problem with "Contacts Waiting" field

anyone?

Super Bronze

CCX 8.5.1 - Scripting - Problem with "Contacts Waiting" field

Hi

You should break the problem down a little.

It's either the return value from the 'get reporting' statistic is wrong or not working, or your actual comparison is wrong/not working.

I would play out the result of the 'get reporting' step using a 'create generated prompt'/'play prompt' combo.

If that plays out what you expect, then try removing the get reporting step and putting in dummy static values via by parameterizing the integer ex

Or post up your actual script so it can be reviewed...

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!

CCX 8.5.1 - Scripting - Problem with "Contacts Waiting" field

I explained that to the TAC and they say it's a bug.

Pretty much like if the get have a problem when it's in the Select resources.

The workaround is to put it outside the Select resource.

The problem is if you want to do a play prompt to tell the caller how many people are waiting in the queue you will have an issue,  it will not give the exact number of people that are waiting in the queue.

I tell them to open a Bug-ID, i will post it here as soon I have it.

thanks

331
Views
0
Helpful
3
Replies
CreatePlease login to create content