Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

CCX SOAP error

Hi ,

I am following the java code example at (https://supportforums.cisco.com/document/97736/uccx-8x-really-simple-soap-client-no-custom-jar), but I have some problem, first part (create xml document) adds strange symbols to it, How can I solve that?

CCX version: 8.5.1.11004-25

when I make a ccx debug to XML I am able to see:

first symbol "U" and before quotation marks always are "\" symbol

U"<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n<soapenv:Envelope xmlns:soapenv=\"http://schemas.xmlsoap.org/soap/envelope/\"><soapenv:Header/><soapenv:Body><mis:GetCallAggregates xmlns:mis=\"http://mis.report.pointers.cz/\"><startDate>2012-04-01T00:00:00</startDate><endDate>2012-04-02T23:59:59</endDate></mis:GetCallAggregates></soapenv:Body></soapenv:Envelope>"

 

I appreciate your help.

 

 

 

 

 

 

3 REPLIES

Hi,I don't think that's a

Hi,

I don't think that's a problem. Strings (and everything) are just arrays of bytes and the UCCX script editor chose to make their representation "enhanced" with quotation marks. The "U" prefix probably means it's Unicode.

G.

New Member

Hi,and what about "\" symbol?

Hi,

and what about "\" symbol? I think web service server won't  understand

it. I tried to make a simple test, this info was saved like xml file then i tried 

to open it with iexplorer and this showed some error.

 

Hi,again, this is just a

Hi,

again, this is just a representation of the String - UCCX uses this for a reason unknown to me. Naturally, if you try to open such garbled text as an XML, it would throw an error in IE.

Let me create a mock service and sniff the real communication, and I will post it to here - believe me, UCCX would show this "decorated" text but the SOAP server would get the real thing.

G.

56
Views
0
Helpful
3
Replies
CreatePlease to create content