Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CLID tcl script problem with UCCX

Our telephone company  does not send the name with the caller  ID, I am testing the advanced version of  an XML directory service from a Cisco Approved developer which works well with standard telephony services on CUCME v8.5.

The CLID Tcl script and XML services work well for normal users who are not part of the call centre, if the name of the customer is in the database, it will be displayed together with the Calling Number on the telephone’s screen.

The problem am facing when I try to use the CLID Tcl script in-conjunction with the UCCX script (am using UCCX version  8.5.1.11004-25), the caller hears silence instead of the voice-prompt  and the agent phone does not ring. I want the agents to know the name of the customer when a call is forwarded to them. When I remove the CLID Tcl script, the UCCX script works well.

What could be the problem? Has anyone experienced similar problems with UCCX and other CLID name-to-numbers scripts?

1 REPLY
New Member

CLID tcl script problem with UCCX

To me it seems like you are playing the phrase on an inactive leg.. So the idea are to play the phrase first and then handoff.

Besure to check which leg you are acting on.

regards Nino

239
Views
0
Helpful
1
Replies