Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CRS script: Get User by Extension not working

Dear all,

I am experiencing some problems when programming in CRS editor an script for IPCCX 5.0(2).

When I try to get a user using the Get User step with the Query Type = Agent Extension and providing the "extensionNumber" it always enters in the Unsuccessful branch.

If I try to do it selecting Query Type = User ID it works perfectly.

I include an attachment as example. When using the "1752" extension I get no agent in the "AgentePorExt" variable. But when using the "PRUEBAS3" id I get the agent in the "Agente" variable and also its associated extension in the "Ext" variable.

Could anybody let me know what is wrong when trying to use the Extension in the Get User step?

Thanks in advance,

BR, Amaia

4 REPLIES
New Member

Re: CRS script: Get User by Extension not working

Dear Amaia,

Have you resolved this issue because I've the same one...

Thanks in advance.

Best regards

Romain JOURDY

New Member

Re: CRS script: Get User by Extension not working

Dear Romain,

I couldn't solve it. In the end I managed to get what I want using the UserID.

Maybe an upgrade of the system solves it.

Plese, let me know if you solve it.

Best regards,

Amaia Lesta

New Member

Re: CRS script: Get User by Extension not working

Dear Amaia,

I solve it!

In fact I'de twice resourceid with same extension.

To verify it you can go on the resource table and check if you have twice agents with the same extension. If it is the case erase one in appadmin and it will ok.

Best regards

New Member

Re: CRS script: Get User by Extension not working

Ok!! Wonderful!! Thanks a lot for your pieace of advice, I will try it.

130
Views
0
Helpful
4
Replies