Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

CRS Server BARS Restore

We use IPCCX 4.0(5) and CCM 4.1.3. I used BARS to backup CRS server.

After BARS backup for CRS server, I re-installed the OS and all necessary patches. I used the same server name and IP address as the original CRS server.

When I tested BARS Restore for CRS, BARS failed when restore reached to 40%. At this point, a message from Restore process stated that the Node (Restore Destination) had some mismatch and need to start CRS installer. When I put the CRS CD 1 in and start CRS installer, a BARS error message ?Unspecified ERROR? appears. Then BARS restore process stops.

The CRS installer continues with CD 1, 2, and 3. Then Server reboots. After server boots up. CRS Control Centre shows that CRS Engine Subsystem Manager is down. Also following three components are failed(in Red):

CRS SQL Server ? Agent

CRS SQL Server ? Historical

CRS SQL Server ? Repository

I tried to restart those three components from CRS Serviceability Utility, did not work.

The doco for CRS BARS restore is quite different from what I have seen in my test.

Any has done CRS BARS Restore? It would be a great help if someone can post here the right procedure for restore.

Thanks,

Wenqian

1 ACCEPTED SOLUTION

Accepted Solutions
Silver

Re: CRS Server BARS Restore

I'm looking at bug ID: CSCsh48057, which contains a very similar error message.

The fix appears to be to apply the 4.0(5)SR1 patch, though I'm not clear on the order in which to apply it and perform the recovery. I'm hoping that after a failed restore, I can apply the patch and then perform the Restore again.

Synptom: While performing backup and restore or during upgrade, operation fails and the following error messages are seen in logs:

While performing Basic Back up and Restore of CRS 4.1(1)Build 62 HA setup

using BARS 4.0.11.3

[10:46:44 AM] FailureResponse id=2 from Session# 1, pArchiveId={70259901-2B82-

-46D4-9EE6-EB0B0C99C963}, errorCode=UNSPECIFIED_ERROR, statusMe-

ssage=remote wizard's failure: com.cisco.crs.archive.JTAPISynch-

ronizationWizard; nested exception is:

com.cisco.servlet.Serv-

letException: null; nested exception is:

java.lang.NullPointe-

rException

[10:46:44 AM] Message received = FAILURE RESPONSE

[10:46:44 AM] Failure response received - 4

[10:46:44 AM] Error: UNSPECIFIED_ERROR

[10:46:44 AM] Closing session

Condition: During backup/restore or upgrade

Workaround: None

13 REPLIES
Silver

Re: CRS Server BARS Restore

Check whether the RTD and Historical data is on ICDSERVERRPT

Community Member

Re: CRS Server BARS Restore

Thanks for reply.

My current situation is that the restoration failed at 73%.

Here is the trace log:

[12:26:39 PM] FailureResponse id=2 from Session# 1, pArchiveId={CA0AD1CC-2736-

-4D85-B0CA-715F6047410B}, errorCode=UNSPECIFIED_ERROR, statusMe-

ssage=unable to process archive component: com.cisco.archive.im-

pl.component.ldap.LDAPArchiveComponent; nested exception is:

-

com.cisco.archive.ArchiveException: Unable to process restore L-

DAP request; nested exception is:

com.cisco.config.util.Confi-

gComponentException: Cannot save node; nested exception is:

c-

om.cisco.wfframework.repository.ProviderUnavailableException:

[12:26:39 PM] Message received = FAILURE RESPONSE

[12:26:39 PM] Failure response received - 4

[12:26:39 PM] Error: UNSPECIFIED_ERROR

[12:26:39 PM] Closing session

Any idea?

Thanks.

Silver

Re: CRS Server BARS Restore

I think I'm getting to the same point as you. Attached are my BARS log and trace files and a screendump of the crash of the BARS restore on the Publisher.

I'm using CCM 4.1(3)sr2 with IPCCX 4.0(5) with BARS 4.0.1100.

I've looked at the fixes in the 4.0(5)SR1 release notes, but I can't see anything which describes this issue (and I'm not sure how I'd apply the patch before recovering the server).

When I initially started the CRS install on the server, I only had the option to "Update Node". I let the CRS install proceed and then reran the installer, and selected Repair then Restore to recover from a BARS backup.

The key error message appears to be:

[03:44:58 PM] Get next message

[03:45:17 PM] FailureResponse id=2 from Session# 15, pArchiveId={036D29B8-CCA-

1-4692-B561-140DE2906795}, errorCode=UNSPECIFIED_ERROR, statusM-

essage=unable to process archive component: com.cisco.archive.i-

mpl.component.ldap.LDAPArchiveComponent; nested exception is:

-

com.cisco.archive.ArchiveException: Unable to process restore -

LDAP request; nested exception is:

com.cisco.config.util.Conf-

igComponentException: Error saving configuration!; nested excep-

tion is:

com.cisco.repository.ldap.ProviderUnavailableExcepti-

on:

[03:45:17 PM] Message received = FAILURE RESPONSE

[03:45:17 PM] Failure response received - 4

[03:45:18 PM] Error: UNSPECIFIED_ERROR

[03:45:18 PM] Closing session

Community Member

Re: CRS Server BARS Restore

I also tried BARS backup/restore using BARS 4.0.12. It failed at the same place, with the same error message.

I will talk to a Cisco tech to find out. Will post here when get any response.

Silver

Re: CRS Server BARS Restore

I'll do the same. Out of interest, are you running SQL2K or MSDE on the node you're trying to recover?

Community Member

Re: CRS Server BARS Restore

Our CRS server is running SQL2K.

Silver

Re: CRS Server BARS Restore

Ours is too, but I'm not sure how relevant this may be. I may get a TAC case raised to try and throw some light on it.

Silver

Re: CRS Server BARS Restore

I'm looking at bug ID: CSCsh48057, which contains a very similar error message.

The fix appears to be to apply the 4.0(5)SR1 patch, though I'm not clear on the order in which to apply it and perform the recovery. I'm hoping that after a failed restore, I can apply the patch and then perform the Restore again.

Synptom: While performing backup and restore or during upgrade, operation fails and the following error messages are seen in logs:

While performing Basic Back up and Restore of CRS 4.1(1)Build 62 HA setup

using BARS 4.0.11.3

[10:46:44 AM] FailureResponse id=2 from Session# 1, pArchiveId={70259901-2B82-

-46D4-9EE6-EB0B0C99C963}, errorCode=UNSPECIFIED_ERROR, statusMe-

ssage=remote wizard's failure: com.cisco.crs.archive.JTAPISynch-

ronizationWizard; nested exception is:

com.cisco.servlet.Serv-

letException: null; nested exception is:

java.lang.NullPointe-

rException

[10:46:44 AM] Message received = FAILURE RESPONSE

[10:46:44 AM] Failure response received - 4

[10:46:44 AM] Error: UNSPECIFIED_ERROR

[10:46:44 AM] Closing session

Condition: During backup/restore or upgrade

Workaround: None

Community Member

Re: CRS Server BARS Restore

It looks promising. I will apply this patch and then try Backup/Restore again tomorrow.

Thanks

Community Member

Re: CRS Server BARS Restore

Hi mmelbourne,

I just completed BARS Restoration test after upgrade CRS 4.0(5) to SR1. Restoration was completed successfully. All CRS functions were restored on the newly installed server.

Thanks a lot.

Wenqian

Silver

Re: CRS Server BARS Restore

What was your final installation order? I've applied SR1 and performed a backup.

Then I've reinstalled CRS 4.0(5) from the installation disks and a difference was it auto-rab the PatchInstall utility and pointed it at the SR1 tar file. I'm just wondering whether it'll reinstall the 4.0(5) binaries from the CDs and overwrite the files the patch replaces?

Community Member

Re: CRS Server BARS Restore

The process for my operation:

* CRS 4.0(5) upgrade to SR1.

* BARS Backup for CRS.

* Install a new OS with the same server name and IP address as the backed up system.

* Install CRS on this server using the same cluster (so only recovery button available here).

* After CRS install, a window pop up, asking to find the SR1 tar file.

* Install SR1 here, it does not need the CRS CD here. It will not re-install CRS.

* After SR1 upgrade, run BARS on a BARS Backup server (I use CCM as backup server).

Silver

Re: CRS Server BARS Restore

For completeness, here's the procedure I went through which finally worked:

Install OS and apply latest patches, e.g. 2000.4.4sr7

Install BARS (as a Target)

Install CRS 4.0(5) from the Installation CDs (During installation, the only option is "Update Node")

Install SQL2K

Reboot

CRSPatchInstaller starts (it prompts for the location of the SR1 tar update file)

[Node Manager terminated 'unexpectedly' during the Patch install, but a reboot allowed the process to repeat successfully]

Reboot

SQLUtility launches and expands the databases

Reboot

[At this point, CRS 4.0(5)SR1 is installed, but without any data, apart from what is stored in LDAP (DCD)]

Install CRS 4.0(5) from the Installation CDs again

Select Repair -> Restore

When instructed, initiate a BARS Recovery on the BARS Server

BARS gets to ~19% and enters a "Suspending State"

Reboot

CRSPatchInstaller runs again to install the SR1 binaries

Reboot

BARS Restore now completes

It does appear that a restore of 4.0(5), and presumably 4.0(5a) is problematic before SR1 is applied.

My recommendation would be to test and apply SR1 at the earliest opportunity.

590
Views
0
Helpful
13
Replies
CreatePlease to create content