Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CRS3.5(IVR) SQL database integration

Hi,

We have IVR (CRS 3.5(2)) integrated with CCM 4.1(3).

I want to integrate the IVR with SQL 2000 database.

Problem - I do not see the Data Source Name when I right click DB Read step using the script editor.I see a blank when I click the drop down arrow of the Data Source Name.

I have configured the Database Subsystem & the service is running(In_Service) in the Engine.

I have configured ODBC on the IVR server using administrative tool.I have configured system DSN & selected SQL server.When I click Test Data souce, it shows "Test completed Successfully".

I have also restarted the engine.

But Still why am I not able to see Data source name in DBRead step.Is there any thing else to be configured??

Regds

KMS

5 REPLIES
Hall of Fame Super Silver

Re: CRS3.5(IVR) SQL database integration

Are you runnig the CRA Editor on the IVR server? If NO then click the Refresh Database Schema button.

Chris

New Member

Re: CRS3.5(IVR) SQL database integration

Also try to restrat the Engine

New Member

Re: CRS3.5(IVR) SQL database integration

I am having the same issue with CRS 3.1. I have restarted the engine after following the instructions to the letter. There is another datasource we have configured from before I was involved that shows up fine. I've duplicated the settings and still no luck in the editor. Refreshing the database scheme doesn't seem to help either.

Let me know if you figure out what keeping your editor from recognizing the datasource.

New Member

Re: CRS3.5(IVR) SQL database integration

What is the status of your data source engine

New Member

Re: CRS3.5(IVR) SQL database integration

Found the problem, at least for my case. We have two IVR servers. I added the data source to IVR1 only. It seems the "Application Engine Hostname" on IVR1 was set to IVR2. Correcting that and then refreshing the database schema in CRA Editor allowed me to choose from the multiple datasources.

295
Views
0
Helpful
5
Replies