Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CTITest fails to work

Platform is IPCC 7.0 Enterprise.

Steps I am executing:

a) Launch CTI test

b) config /hostA roggera /portA 42027 /hostB roggerb /portB 42028

c) open

d) agent_login <ID> <Password> /periph 1000 /instrument <instrument id>

After I issue command (d) I get this :

CTITest: agent_login 79799175 123456 /periph 1000 /instrument 8106

CTITest: 12:44:13 Trace: *** SET_AGENT_STATE_REQ failure response, err:10 (CF_PRIVILEGE_VIOLATION_ON_CALLING_DEVICE), periph err:0 after 0 ms. ***

I looked up the CTIServerMessageRefernceGuide to make sense of the error messages, also turned up the trace level on the CTI server and checked CTITest regedit entries too.

Also want to add that same agent login credentials work fine while using CILTest.

I am pretty new to IPCC and am lost as to what the problem is.

Appreciate any and all help. Thanks.

4 REPLIES
Silver

Re: CTITest fails to work

There doesn't seem to be a password entered for the agent login.... is there supposed to be one?

Try:

http://www.cisco.com/warp/public/78/IPCC_Agent_Prob.html

Cisco Employee

Re: CTITest fails to work

In your login string try using - password ""

Cheers, Darren.

Green

CTITest fails to work

I happened to be trying to test CTITest today. I can certainly connect to the CTI Server and listen in /service ALL_EVENTS mode but when I switch it to /service CLIENT_EVENTS and set up the agent I can see the client events from a companion CTIOS Agent Desktop.

But it won't let me issue make_call - get the  CF_PRIVILEGE_VIOLATION_ON_CALLING_DEVICE.

I know this is a long shot, but does anyone play with this tool and can make it work?

Regards,

Geoff

New Member

CTITest fails to work

Hi,

try to play with the service mask (CallEventMask).

Try with:

config /service 0x1e

920
Views
0
Helpful
4
Replies
CreatePlease login to create content