Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CUIC Scheduler | Error when saving to remote location

CUIC 8.5.4

When attempting to save a report to an SFTP site it is failing.  When I test the connection it shows offline and I recieve the following error:  "Unknown error.  Please contact the administrator."

This has worked before and just stopped working.  I am able to connect to the sftp site using FileZilla and the same credentials, our ftp and network teams report no issues.                  

Everyone's tags (3)
6 REPLIES
New Member

Has anyone solved this issue

Has anyone solved this issue ?>

Are you able to ping the SFTP

Are you able to ping the SFTP site from the CUIC command line interface?

-Jameson

-Jameson
New Member

Yes. We are able to run DRS

Yes. We are able to run DRS from the UCCX machines to the same server. I was able to pull the logs and this what i see.

Caused by: org.apache.commons.vfs2.FileSystemException: Unknown message with code "Could not determine the type of file "sftp://cisco@11.23.11.22/Backup/Reports".".

at org.apache.commons.vfs2.provider.sftp.SftpFileObject.refresh(SftpFileObject.java:95)
at org.apache.commons.vfs2.provider.AbstractFileSystem.resolveFile(AbstractFileSystem.java:366)
at org.apache.commons.vfs2.provider.AbstractFileSystem.resolveFile(AbstractFileSystem.java:317)
at org.apache.commons.vfs2.provider.AbstractOriginatingFileProvider.findFile(AbstractOriginatingFileProvider.java:85)
at org.apache.commons.vfs2.provider.AbstractOriginatingFileProvider.findFile(AbstractOriginatingFileProvider.java:65)
at org.apache.commons.vfs2.impl.DefaultFileSystemManager.resolveFile(DefaultFileSystemManager.java:693)
at org.apache.commons.vfs2.impl.DefaultFileSystemManager.resolveFile(DefaultFileSystemManager.java:621)
at com.cisco.ccbu.cuic.businesslogic.remotelocation.connect.SFTPRemoteFileSystem.dirExists(SFTPRemoteFileSystem.java:132)

What are you using as the

What are you using as the "Directory Path" in the CUIC schedule?  I would make sure that it is a valid unix-style path like this (including the ending slash):

/Backup/Reports/

 

-Jameson

-Jameson
New Member

Was a permissions issue on

Was a permissions issue on the root folder of the SFTP server for that particular user.

Its wierd CUIC tries to get full access of the SFTP server directories.

New Member

This issue was identified as

This issue was identified as a defect CSCuj64096 found in release 8.5.4

 

Symptom:
cuic 8.5.4
- test connection fails while create scheduled report and connect to sftp server.

- "No permission to write on the specified path"

Conditions:

Workaround:  save configuration without testing connection if you are sure the configuration is right.

 

962
Views
0
Helpful
6
Replies