Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CVP 3.1: CVP VXML Server encountered a No Session error

Hey all, I was wondering if someone could help me out here...

I just created a new app in design studio (it is in fact a simple variation of the included HelloWorld microapp) and deployed it. I then modified the routing script to first invoke the standard HelloWorld microapp and then invoke my modified copy. The initial microapp executes just fine but when the system tries to then execute the second application I get a "CVP VXML Server encountered a No Session error" in the log.

Further, if I try to access the VXML page through internet explorer I get "error.condition.baddestination"

I'm probably missing something incredibly obvious but it's just not obvious to me. Any help would be much appreciated.

8 REPLIES
Blue

Re: CVP 3.1: CVP VXML Server encountered a No Session error

Are you invoking the script through ICM?

adignan - berbee

New Member

Re: CVP 3.1: CVP VXML Server encountered a No Session error

Yeah, basically here's what I'm doing Andy:

* The ICM Script sets up the CVP constants and then launches the Cisco supplied test application "HelloWorld". This works fine and you can hear the audio.

* The next step in the ICM script is to launch my Audium vxml test app (which now does exactly the same thing as Cisco's HelloWorld app. It even uses the same audio file as I wanted to eliminate a programmtic error on my part). The app is called "NewHelloWorld"

The second script never plays and I get that No Session error.

Blue

Re: CVP 3.1: CVP VXML Server encountered a No Session error

Strange. Can you post the vxml of your second script as well as a screen shot of your ICM script? I have a few CVP installs out there with CVP and I have worked through most of these issues.

adignan - berbee

New Member

Re: CVP 3.1: CVP VXML Server encountered a No Session error

Yeah, I'll try and grab a screen shot and post it but as for the script, I don't think that matters and here is why:

If I take the Cisco supplied HelloWorld script and re-save it as NewHelloWorld (otherwise unmodified) and then deploy it (to the same server that has the HelloWorld script), I still get the No Session error when I try to invoke the NewHelloWorld script from the ICM script editor once a call arrives.

If I use an ICM script to execute the Cisco supplied HelloWorld, everything is fine. If I take that SAME script and merely change the invoked application to NewHelloWorld (same script, different name; and yes I have made triply sure that all my labels are correct and present as are all the script names in ICM), I get the error. In fact, the only applications that I can manage to invoke at all are the unmodified Cisco supplied microapps.

This would imply to me that I am forgetting something someplace in a config and not doing anything necessarily wrong in the VXML scripting, but I defer to your opinion 8)

New Member

Re: CVP 3.1: CVP VXML Server encountered a No Session error

You even can't see the script from web browser, so the problem may not be in ICM, make sure the IIS and tomcat or Websphere are all healthy.

Wei

Re: CVP 3.1: CVP VXML Server encountered a No Session error

What ever happened here, it seems like I have this exact issue right now!

Green

Re: CVP 3.1: CVP VXML Server encountered a No Session error

Figure it out yet, Chad?

Regards,

Geoff

Re: CVP 3.1: CVP VXML Server encountered a No Session error

Yeah so I changed the call servers on the VXML server and it messed them up. I deleted them from the Map and re-added them, and all the apps are being detected again. Also from your other post it seems I can use the deployapp.bat to solve this issue!

Cheers mate!

Chad

910
Views
0
Helpful
8
Replies
CreatePlease login to create content