Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

CVP 4.0SR2 - OSDM 2.0.3 - error.badfetch

Developing a Speech POC using Cisco Unified CVP 4.0 SR2, Nuance OSDM, OSR3.0 and c2800nm-ipvoice_ivs-mz.124-6.XT.bin as Cisco IOS voice browser

I am getting an error - A VoiceXML error occurred of type "error.badfetch" while invoking an Yes/No OSDM. This is the only OSDM which I have in the speech application.

Enabled debug (debug voip ivr all, debug http client all & debug vxml all) in the G/W and tried debugging the VXML G/W logs. But couldn't understand why error.badfetch occurs?

I am posting the logs captured from the G/W. Please help me to understand why the error.badfetch occurs and also help me to resolve the issue.

Thanks in advance

-Sethu

4 REPLIES
Cisco Employee

Re: CVP 4.0SR2 - OSDM 2.0.3 - error.badfetch

Hi Sethu,

OSDM is provided as it is as a library and request a DEV Contract with Cisco AS for support on any customisation.

As a general reference badfetch is usually caused by the file not being available or loaded at the request time because of it size or miscaching.

Regards,

Riccardo

Re: CVP 4.0SR2 - OSDM 2.0.3 - error.badfetch

Thanks for the quick response.

We do have a Developer contract with Cisco. I have two questions:

1) What is the minimum & maximum file size supported for loading?

2) How do we know there is a miscaching and how it can be avoided?

Thanks!

-Sethu

Cisco Employee

Re: CVP 4.0SR2 - OSDM 2.0.3 - error.badfetch

Hi Sethu,

please raise a request that way on the alias since it is free once you have the contract and there are people to assist.

There is not a minimum, this are the recommended settings:

ivr prompt memory 15000

http client cache memory pool 15000

http client cache memory file 600

I would recommend to hold prompt size as small as possible and eventually concatenate them to improve response, a basic measurement would be to avoid prompts larger then 1 MB.

You could check on cache occupancy by looking at it this way:

sh http client cache brief

Hope this helps.

Regards,

Riccardo

PS Please rate useful posts accordingly

Re: CVP 4.0SR2 - OSDM 2.0.3 - error.badfetch

I do have the same recommended cache configurations and prompt memory settings. But still getting the same error.

305
Views
0
Helpful
4
Replies
CreatePlease to create content