Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CVP Reporting Server new installation

Hello,

I am in the process of a new CVP Reporting Server installation. I have installed the Reporting component, added the reporting server to the Operation Console OAMP and modified the VXML Server config.

When I try to "save & deploy" the reporting server configuration, I get the following error:

Unified CVP Reporting Server device with IP Address: <IP_Address_of_Reporting_Server> and Hostname: <cvp_rpt_hostname> operation failed. Device could not be reached.

I have checked the CVP log for error and found the below logs occured in the same time as the "save and deploy". Below are error taken C:\Cisco\CVP\ error logs:

%CVP_8_0_Infrastructure-3-SNMP_CONNECTION_FAILURE: %[port_id=5516][retry_time_in_minutes=0]: Could not bind serviceability manager to port.  Retrying in specified minutes. [id:9910]

%CVP_8_0_Infrastructure-0-START:  No Subsystems have been started.  Have you configured your server yet? ; Make sure <CVP_HOME>\conf\propFileList.properties is loading "system" and that <CVP_HOME>\conf\system.properties lists at least one subsystem to load. [id:1033]

Am I missing something in the setup? Any advice is appreciated.

Thanks,

Justine.

Everyone's tags (3)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

CVP Reporting Server new installation

Hi Justine,

Please confirm that on the reporting server "cvp call service is running or not.

If its not running enable it.

Also run the URL "

http://:8000/cvp/diag" and check what does the status of the reporting server shows

If it shows UP and still OAMP states its unreachable

- remove the reporting box from Oamp

- Reboot the server 

- Once it comes up confirm the call server service is running

- add it back to OAMP

- Map it to all the call servers, reboot the call serveres

and se eif it helps or not

Thank you

Anuj

New Member

CVP Reporting Server new installation

Hi Justine,

You need to restart the CVP Operations Console box as well when adding a new reporting server (in addition to the steps mentioned by Anuj).

Let me know how it works!

E.B.

10 REPLIES
New Member

CVP Reporting Server new installation

I forgot to mention that the CVP Reporting Server is showing as NOT REACHABLE in the Operations Console OAMP.

CVP Reporting Server new installation

Hi Justine ,

Do you have the hostname  entry of the CVP Reporting Serve in the DNS? Please try pinging this hostname some other box to make sure that it is reachable by hostname also.

Hope it helps.

Anand

Pls rate helpful posts !!

New Member

CVP Reporting Server new installation

I tried to ping the Reporting Server from the Operations Console Server using hostname and it worked.

Cisco Employee

CVP Reporting Server new installation

Hi Justine,

Please confirm that on the reporting server "cvp call service is running or not.

If its not running enable it.

Also run the URL "

http://:8000/cvp/diag" and check what does the status of the reporting server shows

If it shows UP and still OAMP states its unreachable

- remove the reporting box from Oamp

- Reboot the server 

- Once it comes up confirm the call server service is running

- add it back to OAMP

- Map it to all the call servers, reboot the call serveres

and se eif it helps or not

Thank you

Anuj

New Member

Re: CVP Reporting Server new installation

Hello Anuj,

Thanks for the steps. I have  I have tried to remove the reporting server from OAMP, reboot the call servers and add it again to OAMP.

As a result, I am still getting the same message on OAMP.

However, in the CVP logs I can see a new error message:

Apr 27 2012 12:00:04.963 +0300: %CVP_8_0_RPT-3-REPORTING_DB_ERROR_MSG:   (Database: cvp_data) Failed running the stored procedure sp_got_space(): java.sql.SQLException: com.informix.asf.IfxASFException: Attempt to connect to database server (cvp_db_) failed.: java.sql.SQLException: com.informix.asf.IfxASFException: Attempt to connect to database server (cvp_db_) failed. (DBScript.testPurgeNeeded)

java.sql.SQLException: com.informix.asf.IfxASFException: Attempt to connect to database server (cvp_db_) failed.

at com.informix.jdbc.IfxSqliConnect.(IfxSqliConnect.java:1319)

at com.informix.jdbcx.IfxSqliConnReUsableConnection.(IfxSqliConnReUsableConnection.java:60)

at com.informix.jdbcx.IfxPooledConnection.getClientServerReUsable(IfxPooledConnection.java:346)

at com.informix.jdbcx.IfxPooledConnection.establishConnection(IfxPooledConnection.java:288)

at com.informix.jdbcx.IfxPooledConnection.(IfxPooledConnection.java:93)

at com.informix.jdbcx.IfxConnectionPoolDataSource.getPooledConnection(IfxConnectionPoolDataSource.java:126)

at com.cisco.cvp.reporting.backend.BaseScriptHandler.getConnection(BaseScriptHandler.java:507)

at com.cisco.cvp.reporting.backend.PurgeHandler.testPurgeNeeded(PurgeHandler.java:669)

at com.cisco.cvp.reporting.backend.PurgeHandler.runReportingDbPurge(PurgeHandler.java:427)

at com.cisco.cvp.reporting.backend.PurgeHandler.runPurge(PurgeHandler.java:154)

at com.cisco.cvp.reporting.backend.PurgeHandler.run(PurgeHandler.java:58)

at com.cisco.cvp.reporting.backend.DBScript.runScript(DBScript.java:81)

at com.cisco.cvp.reporting.backend.DBScript.main(DBScript.java:215)

Caused by: com.informix.asf.IfxASFException: Attempt to connect to database server (cvp_db_) failed.

at com.informix.util.IfxErrMsg.getLocIfxASFException(IfxErrMsg.java:810)

at com.informix.asf.Connection.openSocket(Connection.java:1769)

at com.informix.asf.Connection.(Connection.java:277)

at com.informix.jdbc.IfxSqliConnect.(IfxSqliConnect.java:956)

... 12 more

Caused by: java.net.UnknownHostException:

at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:177)

at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)

at java.net.Socket.connect(Socket.java:520)

at java.net.Socket.connect(Socket.java:470)

at java.net.Socket.(Socket.java:367)

at java.net.Socket.(Socket.java:180)

at com.informix.asf.Connection.openSocket(Connection.java:1716)

... 14 more

[id:4012]

I have checked the spelling of the Informix database name in %INFORMIXDIR%\etc\%ONCONFIG%. It is correct. It seems that the database name is misconfigured somewhere?

Thanks,

Justine.

Cisco Employee

CVP Reporting Server new installation

Looks like the reporting server is not able to run the midday or midnight purge

whats is the hostname provided to this server ?

I assume the reporting server is on a sepearate box and not on the call server - correct ?

what is the version is it 8.5(1) ?

are you able to login into the informix database with any of these accounts - cvp_dbadmin \ cvp_dbuser \ informix ?

Can you make sure these three accounts are not locked and password never expires box is checked ?

I would suggest you to open up a TAC case in this regard - looks like apart from OAMP reporting server itself has major issues with respect to the datase

Thank you

Anuj

New Member

CVP Reporting Server new installation

Hello Anuj,

The reporting server's hostname is CVPRPT.

It is on a separate box.

Version 8.0

I have created a new datasource in CUIC that points to the CVP Reporting Database and I have tested the 3 users you mentioned: the database is ONLINE for all users.

Can you advise where to check about the account expiry thing?

Thanks again,

Justine.

New Member

CVP Reporting Server new installation

Hello Anuj,

are you able to login into the informix database with any of these accounts - cvp_dbadmin \ cvp_dbuser \ informix ?

Can you make sure these three accounts are not locked and password never expires box is checked ?

When I'm not able to login with those 3 accounts to the database, how do I proceed?

Thanks,

Justine.

New Member

CVP Reporting Server new installation

Hi Justine,

You need to restart the CVP Operations Console box as well when adding a new reporting server (in addition to the steps mentioned by Anuj).

Let me know how it works!

E.B.

New Member

CVP Reporting Server new installation

I missed that little detail.. My reporting server is UP now in the Operations Console OAMP Thanks

2547
Views
0
Helpful
10
Replies