Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CVP Streaming Audio - Helix Discontinued!

We've been using Helix to play a stream that the Gateways can play back.  Helix was chosen as the only Streaming source that Cisco said they supported.

Our licence expired a week ago and we could not work out how to get another one, turns out RealNetworks are no longer offering it as a product!!!!  Currently its still running but if the service or the server restarts we'll lose the stream.

So we're looking at other options.  Has anyone used anything other than Helix?  Currently VLC looks like it might do the trick but working out the right options for the command line is interesting!  Anyone else using VLC or can recommend another streaming product.  Paid or free, doesn't matter!

 

Thanks

9 REPLIES

Hi,yes, VLC is nice and easy

Hi,

yes, VLC is nice and easy if you do not require anything special (other than a streaming service).

Our company has been using GStreamer (via JNI/Java) and it's good but it's more like an SDK and it requires programming, naturally.

G.

New Member

Thanks Gergely, we only need

Thanks Gergely, we only need the streaming so it looks like VLC will do the trick.

Have you used it at all?  I can get it running via the GUI but ideally want to utilise the command line to run it (so it can be set up as a service for when Windows starts), can't seem to figure out the options I need to put though, all the different modules!!! Any ideas?

Hi, yes, actually, just for

Hi, yes, actually, just for simple streaming. Not on Windows, though, but on a Ubuntu server (12.04 LTS if I am not mistaken).

I know the configuration might be a bit overwhelming but there's a fair number of tutorials available, for instance, here: http://minimaldevelop.com/blog/how-to-setup-streaming-server-via-vlc/

G.

New Member

Ah - yeah I have to use

Ah - yeah I have to use windows as we had a 2008R2 installed for Helix, and have to use the same server....

Theres a few guides for Windows, but not for exactly what we're doing, so trial and error I think! :)

New Member

Well I've tried to get the

Well I've tried to get the gateway to play it with no joy.  Set up the stream, I can connect to it from another pc with VLC and play it back, and the codec is correct for CVP.  The gateway connects and then bombs out with invalid stream info - as seen in the attached rtsp debug from the GW.

Same as was posted here with no comments:

 

https://supportforums.cisco.com/discussion/12172956/ios-rtsp-incompatibility-vlc-server

 

Tried on my lab with the IOS at 15.1(4) M2 and also on the live system with 15.3(3) M3.  Tried using both 554 and 8554 as ports.  Shame Helix got binned - "it just worked" lol!

Hi, would you mind posting

Hi, would you mind posting the config params for VLC? This SDP information element looks kinda strange to me:

c=IN IP4 0.0.0.0

Thanks.

G.

New Member

Just running it from the GUI

Just running it from the GUI at the moment to get that working before getting the command line to work.  But the GUI stream options render together to make:

 

:sout=#duplicate{dst=rtp{sdp=rtsp://:8554/stream1.wav},dst=display} :sout-all :sout-keep

Is that what you were after?

Cheers

Hi, yes, actually. Thanks.I

Hi, yes, actually. Thanks.

I left the office already so I cannot test it at the moment but I will try that tomorrow. G.

 

New Member

Much appreciated!!

Much appreciated!!

276
Views
0
Helpful
9
Replies
CreatePlease to create content