Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CVP with SIP and FXO

Hi

I have two fxo ports. I want to configure SIP at my Gateway. Already I have configured FXO port and Dial-Peer at my SIP Gateway. when I am dialing my number it give sontinuousl ring tone. And its taking my mobile balance also....

How Can I go further.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Green

Re: CVP with SIP and FXO

There could be a number of things misconfigured ... but one thing I do observe - you don't have the "handoff" application.

service handoff flash:handoff.tcl
  paramspace english index 0
  paramspace english language en
  paramspace english location flash
  paramspace english prefix en

Please describe the call in more detail.

Are you using an analogue phone connected to the FXO port (I usually use an FXS card for this)?

What number are you calling?

Does it start the switch leg and start your ICM script?

Do you have an explicit "Send To VRU" node? Is it working?

Is the VRU transfer number coming back to the voice gateway? Why don't you use "Send To Originator" for that label?

Is the "request instruction" coming back up through the CVP PG to find your script and resume it?

Can the system find where the correlation ID lives (DNIS length matches length of VRY transfer label)?

Regards,

Geoff

Re: CVP with SIP and FXO

Were you able to get to a CVP applicatoin via the FXO/FXS port?  If so, I would be curious to see your GW configuration as I have a 2811 and would like to build a lab of my own.

Thank you,

david

8 REPLIES
Green

Re: CVP with SIP and FXO

Can you provide a more detailed explanation?

Regards,

Geoff

New Member

Re: CVP with SIP and FXO

hi

I am using the bellow products

1. 2 FXO port

2. voiceGateway 2821 with IOS c2800nm-spservicesk9-mz.124-15.T9.bin

3. CVP 7.0

4. ICm 7.5

I have configured My Analog Vocieport and Sip dial-peer witout proxy which is as attached. My CVP SIP static rout  configuration is also atached here.

When I am dialing that number I can heat the engaged tone.

Kindly suggest.

Best regards

Sultan Al Arif

Green

Re: CVP with SIP and FXO

There could be a number of things misconfigured ... but one thing I do observe - you don't have the "handoff" application.

service handoff flash:handoff.tcl
  paramspace english index 0
  paramspace english language en
  paramspace english location flash
  paramspace english prefix en

Please describe the call in more detail.

Are you using an analogue phone connected to the FXO port (I usually use an FXS card for this)?

What number are you calling?

Does it start the switch leg and start your ICM script?

Do you have an explicit "Send To VRU" node? Is it working?

Is the VRU transfer number coming back to the voice gateway? Why don't you use "Send To Originator" for that label?

Is the "request instruction" coming back up through the CVP PG to find your script and resume it?

Can the system find where the correlation ID lives (DNIS length matches length of VRY transfer label)?

Regards,

Geoff

New Member

Re: CVP with SIP and FXO

Hi Geoff

Thanks for the update. I have checked that I have not configured that handoff.tcl application. Today is my off day tomorrow I will configured that. From the service provider side I have two analog phone number(029570838 and 029570839). These two numbers are connected with my two FXO port. I dont have any FXS card with my gateway.

from the CVP logs I cant see that my calls are goign to CVP. even I cant hear CVP error tone any more.

please guide me for the further.

I will get back to tomorrow.

Best Regards

Sultan Al Arif

New Member

Re: CVP with SIP and FXO

Hi

I have configured that handoff.tcl service @ gateway application but no luck. Let me tell about the whole scenario.

1. I have 2 PSTN line conneted with my 2 FXO port (029570838 and 029570839). My Gateway IP is a subinterface IP (10.10.30.254), which is communicating with data and voice VLan.

2. I want to connect my Gateway and CVP(10.10.30.51). When I am dialing those two numbers I am getting some kind of engage tone. and its taking my charge per minute.

3. I can not hear any CVP error tone .

4. My progger A, Progger B and HDS ips are 10.10.30.31,10.10.30.41 and 10.10.30.21.

5. First I want to hear CVP error tone from my Gateway then I want communicate with ICM.

I am realy stuck on this point. Kindly help me..

Best Regards

Sultan Al Arif

New Member

Re: CVP with SIP and FXO

Hi

The problem is solved. At the first time I have configured wrong FXO configuration. Thanks ...

Re: CVP with SIP and FXO

Were you able to get to a CVP applicatoin via the FXO/FXS port?  If so, I would be curious to see your GW configuration as I have a 2811 and would like to build a lab of my own.

Thank you,

david

New Member

Re: CVP with SIP and FXO

Hi

Sure I will provide you all the information you need to integrate CVP7 with FXO and ICM. I have configured my Gateway as bellow.

1. My FXO card dose not show caller Id.

2. As I dont have caller ID I have made a Plar connectiona @ my FXO port.

3. I have made a Inbound POT dial-peer with that Plar number

4. After that I have configured as usual SIP-dial peer with out sip porxy.

I think Its clear to you.

Best Regards

Sultan Al Arif

452
Views
0
Helpful
8
Replies