Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Debug CRS - reactive script fail in UCCX 10.5

 

Hi everybody, 

Recently we have change our CUCM 8.6 to CUCM 10.5, also the CCX has been changed from 8.5 to 10.5 as well

When I tried to use CRS editor 10.5 Debug > "Reactive Script..." as usual ... 

It shows error message ...

Engine hostname list is empty
Check the LDAP for enabled Unified CCX Engines

I tried to add a DNS record and point to UCCX in my local PC 
C:\windows\system32\drivers\etc\hosts

Successfully ping the UCCX hostname from my PC

but the error still existed

Am I missing some settings in UCCX10.5 version?

 

Thanks in advance

Sam

 

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

My customer added the UCCX

My customer added the UCCX name to the DNS server and debugs began to work. 

14 REPLIES
New Member

Nobody has this experience

Nobody has this experience and solution?

New Member

Hi Sam, unfortunately i am

Hi Sam,

 

unfortunately i am experiencing the same issue in my lab. have you found a solution?

 

Regards,

 

Henrique

Silver

I had a similar issue with an

I had a similar issue with an 8.x server after an upgrade.  I was able to log into CRS Editor and when I would attempt to do a reactive debug it would fail.  I don't recall the exact error message but the issue was with the RMI port (6999) being blocked by an iptable.

 

Are you able to telnet to the server on port 6999?  I verified that 6999 is still the port being used in UCCX 10.5.

 

This was a few years ago and unfortunately I wasn't able to find the TAC case to get more details. 

 

DJ

New Member

thanks for you message.yes, i

thanks for you message.

yes, i just tried and i was able to telnet 6999.

asked my customer to add the hostname to the dns server.

I already reinstalled the editor.

Silver

Sorry, I'm out of ideas and

Sorry, I'm out of ideas and unfortunately don't have a 10.5 environment to test in.

DJ

 

New Member

ahá ! !I`ve just managed to

ahá ! !

I`ve just managed to get it working. in fact the DNS entry must be configured properly!

Thanks.

Can you explain what you mean

Can you explain what you mean by 'configured properly'?  I'm hitting the same problem and I have a DNS A-record in Forward Lookup Zone and a ptr in the Reverse Lookup Zone.

New Member

My customer added the UCCX

My customer added the UCCX name to the DNS server and debugs began to work. 

New Member

local windows DNS also works

local windows DNS also works.

you just need to check what the editor is trying to resolve (i used for example, wireshark to discover that).

New Member

Finally, I have uploaded a

Finally, I have uploaded a valid license to UCCX 10.5 and the problem is fixed. 

So, I would suspect the Demo License in UCCX 10.5 has problem

New Member

I have this issue also!

I have this issue also! however i had my forward and reverse DNS working fine and it still did not work.

 

To solve it i had to go into the logs

C:\Program Files (x86)\wfavvid_1051\log\MEDT\ cisco0-1MEDT04.log

 

I found in the logs that said the following.

(everything that says YOURHOSTNAMEYOURSERVER is actually your hostname when you do show status in admin CLI i replaced mine for security purposes.)

 

"java.rmi.UnknownHostException: Unknown host: YOURHOSTNAMEOFYOURSERVER.name; nested exception is"

"java.net.UnknownHostException: YOURHOSTNAMEOFYOURSERVER.name"

 

i am not sure why it had my hostname and then the .name after 

 

however i made a record in my hosts file on windows C:\windows\System32\drivers\etc\hosts

This is what it should look like in your hosts file

 "yourhostnameofyourserver.name 192.168.2.5" or whatever your ip is of your server.

 

i am currently working on a tac case to see why it wants to go to myhostname with the .name after it.

 

Thanks,

New Member

the domain name was set wrong

the domain name was set wrong.

 

it was set to name

 

probbly cause the syntax is confusing 

 

admin:set network domain ?
Syntax:
set network domain name
name    mandatory   domain name the system resides in

 

it makes me think you have to do "set network domain name contoso.com" but what is really supposed to be is "set network domain contoso.com"

 

haha

 

New Member

It's a bug. Cheek here..

It's a bug. Cheek here..

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCun00611/?referring_site=bugquickviewredir

Maybe, but not this time. 

Maybe, but not this time.  All the user ID's were lower case.  I duplicated this in the lab environment.  It was the version of the editor, not the bug you referenced. 

1498
Views
20
Helpful
14
Replies
CreatePlease login to create content