Cisco Support Community
Community Member

Error attemtping to connect to DbAgent


There is a document open for this error, and I did reply on the document by mistake! Ment to open discussion.

The document is:

I have exact same error on the actual AW Distributor PC.

And the fix does not apply, because the PC is Windows 2003 Server SP2!  and when I try to apply the hotfix it says I already have more recent updates applied.

When I try to run "Configuration Manager" it says: "Error attemtping to connect to DbAgent"

At the same time the following shows up on "Distributor updateaw" process window:

22:25:07 Trace: [client: Launcher(upcc)] AW Operation WaitNamedPipe on Pipe \\WIN3K1\pipe\ICM\lab01\RouterA\ failed.

22:25:11 Trace: Info: Trace client on pipe 0x1ec disconnected.

  Last API Error [109]: The pipe has been ended.

Anyone has any idea about this one? or how to troubleshoot this?

Thanks a lot,

Community Member

Error attemtping to connect to DbAgent

anyone any tips?

or how to troubleshoot this at all???


Cisco Employee

Error attemtping to connect to DbAgent

Not sure why your aw is not able to connect to the dbagent but you could try the below basic checks and see if they help

.Please Check if the Named Pipes is enabled and has higher priority than TCP/IP, on both Logger and AW Server.

.Check if their Server's clock is in synch with the Primary Domain Controller's Clock.

.Check if they have any Domain related issues on their servers (try using nslookup command).

.Check if the if the logged in user (making configuration changes) has necessary privileges /proper authentication and is part of domain.

.Confirm if they are not running into any public network hiccup's between AW and Logger.

.Also, at times the issue can happen when DNS cannot resolve host name to IP address, hence request you to run the local AW-setup and change all host name to IP Address, i.e. instead of using hostname for Rogger-A/B, try using IP Address. To do this stop the Distributor Services and re-run the setup from the ICM Admin Workstation folder on the AW's desktop Select the AW and then click "edit", change every hostname in the next pages to IP and then complete the setup.

.Verify if the CC can be pinged by hostname and ip address from AW and vice versa whenever you try making a configuration change.

. Check if the server and workstation service is running on both the CC and DAW.

.Turn up the logging for dbagent to ffff and see if it gives you any clue.


Community Member

Error attemtping to connect to DbAgent

Hi Shirish,

Thank you very much for taking time to help me out with this.

I've checked all that you asked.

1) Named pipes is enabled on both servers. and it is on top of the list, just above TCP/IP.

2) I've synched the clock. so now all the clocks on PDC +ROGGER +AW are running same time. It was in wrong time zone on PDC. but same result.  I restarted servers too just in case. all of them including PDC.

3) all the names resolve fine. but I'm not using names anyway, in router/logger/aw configuration I've set IP addresses.

4) the user I'm using is in "Domain Admin" group. actually I'm using "Administrator" user from domain controller.

5) It's can't be running into any public network problems, because this is lab environment, and it's all on the same VMWARE sharing same network adapters.

6) As mentioned in 3) I'm using IPs already in all configuration options.

7) Everything pings, by name and by IP too.

8) All the services are running on the CC and AW.

This is a lab environment. so I can make allt he necessary changes and tests.

I'm will try setting the logging to FFFF on dbagent, and see what happens. will come back with results.

meanwhile if anyone has any more ideas, please share.


Community Member

Error attemtping to connect to DbAgent


I don't know if you are still facing the problem, but we could solve it enabling File and Printer Sharing, that is on Public

Network Card Settings in the advanced tab.


T. Miyahira

CreatePlease to create content