Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Finesse CUIC Gadget hanging: "Requesting report execution..."

My company is getting ready to deploy Cisco UCCE 10.5 with Finesse 10.5(1). From what we have heard through Cisco partners, IE is not the preferred browser to use with Finesse.

 

One of our business requirements for Finesse is to have a dashboard displayed with Precision Queue statistics to which the agent does not necessarily belong. We plan on doing this using a CUIC dashboard with the CUIC gadget on the agent desktop. However, in Firefox and Chrome, the CUIC gadget gets stuck with a message that says, "Requesting report execution..."

 

We have had certificate issues with IE, and as such, would prefer to use Chrome or Firefox (preferably Firefox, since Chrome has some issues with resizing Finesse gadgets). I found a similar question here: https://communities.cisco.com/docs/DOC-50278, but the final reply was a bit vague for me. I have tested creating an iframe in a separate html page that links to the CUIC dashboard, and it also does not work in Firefox or Chrome, but does work in IE. This indicates that the issue is not a Finesse issue per se, but more browser related.

 

Does anyone know of a workaround to get the CUIC dashboard to load in Firefox or Chrome, or is the CUIC gadget simply unusable with those browsers, forcing us to use IE?

 

Thanks in advance,

Stuart Walker

Everyone's tags (1)
6 REPLIES
Community Member

Hi,I've tried with the dCloud

Hi,

I've tried with the dCloud environment. it is UCCX 10.5.1.10000-24.

Neither CUIC or EmbeddedApp gadgets from Cisco Developer community can render a CUIC permalink report in Finesse Desktop if I use Firefox. It keeps saying Requesting Report Execution for ever.

Using Internet Explorer made the trick.

On dCloud it is IE9 and FF27.

Using my machine with FF34 it is the same.

 

there must be some issue between the gadget and FF iFrames...

 

Have you found a solution?

Have you tried upgrading the UCCX to the latest SU or 10.6?

Rui

Community Member

The issue with Firefox has

The issue with Firefox has been fixed.

Silver

Hi,

Hi,

How did you fix this?

Thanks

Community Member

Hi Brian, 

Hi Brian, 

have you ever received an answer about this issue? I'm experiencing the same issue.

Thanks! 

Community Member

It's been awhile, but I

It's been awhile, but I believe the issue was resolved by allowing https permalinks in iframes. However, for my organization, we found that CUIC permalinks use way too much bandwidth, which was causing network issues at remote offices. So, we abandoned using CUIC permalinks in the Finesse desktop, and custom-built a gadget that gets its data from an XML file, which is refreshed by a scheduled task, which hits the permalink once and stores the resulting XML on the Finesse server itself. Very complex and convoluted, but we had to work around the limitations that come with CUIC permalinks.

We're still on version 10.5, but we hope to upgrade soon. I would recommend against using CUIC gadgets in Finesse, unless the CUIC report(s) refresh interval is over 20 minutes or so.

Community Member

Hi Stuart, could you please

Hi Stuart, could you please share the solution, since I've just started experiencing the issue? I'd really appreciate it! Thanks!

574
Views
0
Helpful
6
Replies
CreatePlease to create content