Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Historical reports break after integration with AD

We just integrated our Call Manger 6.x and our Unified Contact Centre Express 7.0(1)SR01_Build210 to integrate with our Microsoft AD.

When our user goes to run historical reports, they no longer can access them. However it gives us the message no data within that date range.  However, we can bring data up before July 1st of this year ( we just integrated the AD this past weekend).  They were able to get the reports out last month.

I check the table ContactCallDetail in the db_cra database and all the information is there.  The reporting services is runing fine.  We rebooted both the services and still nothing.

Am I missing something with the integration?

Thanks.


Gary

Everyone's tags (4)
13 REPLIES
New Member

Re: Historical reports break after integration with AD

Hi Gary,

I am facing same problem with different scenerio.

At my side, IPCC Server and Call Manager are installed on different machines. Also there are HA node for both for recovery purpose. (Total 4 machines)

All the clients where HR Client is installed are with AD.

I am facing same error. the thing I noticed is that, HR Client is not capturing the reports from primary server but is trying to fetch/get records from secondry server.

Note: At my side, issue is not with default reports but is with customised reports that use user defined tables and procedures.

If you find any help regarding this, kindly let me know.

Regards

Kashif Surhio

New Member

Re: Historical reports break after integration with AD

I will.  We have separte publishers & subscribers for both also.

Thanks for the tip, I checked the database on the subscriber and sure enough it's pulling from that..

New Member

Re: Historical reports break after integration with AD

Interesting.  If I shutdown the secondary server, the reports come up fine.  Once the secondary server is back online, then the reports

point back to it.  However the configuration is indicating the IP for the primary server, need to play around with that I think.


Gary

New Member

Re: Historical reports break after integration with AD

In the Historical Reporting Configuration page, does it matter the sequence of servers.  The subscriber server is listed first and the publisher is listed 2nd.


Gary

Cisco Employee

Re: Historical reports break after integration with AD

Hi Gary,

By default HR client always grabs the data from the secondary box irrespective of what server is actively handling the calls. HR only collects the data from the primary server when secondary is down.

From your test looks like the data is not being replicated between the UCCX serveres. Thorugh Appadmin - system - control center - component activation - for the secondary box reactivate all the datastore components and see if it helps

Regards

New Member

Re: Historical reports break after integration with AD

Hi,

Thanks for the info. I'm already there actually trying to do this, however when I goto

Appadmin - system - control center

There is no component activation selection/link anywhere.  Just Servers / Features and under them just basic info like services etc.

Gary

Cisco Employee

Re: Historical reports break after integration with AD

will it be possible to upload the screen shot

Thanks

Anuj

New Member

Re: Historical reports break after integration with AD

Sorry for the late reply, here is the screen shot.

Cisco Employee

Re: Historical reports break after integration with AD

You are selecting the server - Once you are in system - control center dont select any server and you should see component activation page on the top right corner  (see the screen shot attached)

once in there select the secondary server and restart the data stores

Hope this helps

Anuj

New Member

Re: Historical reports break after integration with AD

That's the thing, I don't select anything after.  Once I select Control Centre that is the page that gets displayed.    

Gary    

New Member

Re: Historical reports break after integration with AD

When I select Control Centre, it directs me to

http:///appadmin/Control?request_type=controlcenter.listnodes

Re: Historical reports break after integration with AD

just click on All Servers right above PHONE-UCCX1.

Anthony Holloway

Please use the star ratings to help drive great content to the top of searches.
New Member

Re: Historical reports break after integration with AD

I've tried that already and it just stays at the same screen. Nothing changes.

558
Views
0
Helpful
13
Replies
CreatePlease login to create content