Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Holiday Script variable problem

Hi,

I'm installing an holiday script on a UCCX 9.0.2 Premium.

Here's my problem:

on my script i have

XMLDocument = Create XML Document (XMLDocument)

the variable is:     NAME:XMLDocument     TYPE:Document          VALUE: DOC[holidays.xml] @ [en_GB]

Everytime i run a debug the value of the variable above turns to null, giving on next step the error: "Source document variable "XMLDocument" has null value."

I´m on ccx editor 902

Thanks.

  • Contact Center
1 ACCEPTED SOLUTION

Accepted Solutions

Holiday Script variable problem

Depending on the version of UCCX 9.0.2 (base) you are probably running into a bug that I found and then was acknowledged by this post: https://supportforums.cisco.com/message/3930553#3930553

Unfortunately if you are..and my hunch is that you are..you'll need to debug in Reactive Mode.

5 REPLIES

Holiday Script variable problem

Hi,

use the Set step to assign the value of the variable.

Also, I am not sure about the syntax. Try Set XMLDocument = DOC[holidays.xml] @ L[en_GB]

G.

New Member

Holiday Script variable problem

Hi Szabo,

Thank you for your response.

I've already tried and the Set XMLDocument does not alter anything the value after i start the script remains null.

Paulo Pereira

Holiday Script variable problem

Hi Paulo, can you please make sure the holidays.xml file is in the correct directory in the Document Repository?

G.

Holiday Script variable problem

Depending on the version of UCCX 9.0.2 (base) you are probably running into a bug that I found and then was acknowledged by this post: https://supportforums.cisco.com/message/3930553#3930553

Unfortunately if you are..and my hunch is that you are..you'll need to debug in Reactive Mode.

New Member

Holiday Script variable problem

Hi,

Thank you very much, i've passed 2 day´s working around this.

Thank you to all the people in this Forum.

Cheers.

Paulo Pereira

156
Views
4
Helpful
5
Replies
This widget could not be displayed.