Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

How to enable screen pops with UCCX 8.5

I have done a lot of reading on this, but I'm not finding enough information on it to help (or at least not in a way that I understand).  I am trying to create an HTML based screen pop that would contain Enterprise Data pulled from the Microsoft CRM record of the person calling.  Within that screen pop would also be a link to the actual CRM record for the agent to follow.

I've read things like need to use HTTP GET and HTTP POST, but I don't see those as steps within the Script Editor.

The web page would either be using the integrated browser in CAD or a new IE (or other) browser window, external to CAD.

Is this possible?  If so, how would I, at the very least, get started.

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

HiYou configure the actions,

Hi

You configure the actions, and then you have to assign them to the workflows based on conditions of the call.

For example - you might pass a variabel from the script, that tells CAD to use a different action (i.e. different pop) for different call types or so on. If you want all calls to just fire a standard action, you'd normally set it for any ANI.

E.g.

  • Voice workflows
  • 'Answered'
  • New... rule
  • 'Enabled rule' checked
  • Edit condition one, set 'calling#' is not empty
  • Then assign your action

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
11 REPLIES
Super Bronze

HiThe scripts control the

Hi

The scripts control the call flows up to the point of delivery to the agent.

Within those scripts you might do (for example) a DB dip to find some info about the caller, or some other form of lookup, even something as simple as getting the caller to punch in an ID on the phone.

That information will be set in 'set enterprise data' steps, this 'tags' the data to the call so it is sent to CAD as well as optionally going into the UCCX HR DB (depending on which Enterprise Data variables you use).

Once the call goes to CAD, CAD drives the 'pops' or other actions. These are defined in 'Desktop Administrator' - install this from the Plugins page where you get the Agent from.

You'd be best to read this and then come back with any further questions:

http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/cust_contact/contact_center/crs/express_8_5/user/guide/cda85ccxug-cm.pdf

Regards

Aaron

Please rate helpful posts..

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Thanks Aaron, that document

Thanks Aaron, that document looks very helpful.  Any thoughts on how I would go about isolating the changes I made in Desktop Administrator so they don't effect everyone?

Super Bronze

HiSure - in the 'Workflows'

Hi

Sure - in the 'Workflows' section create a new Workflow group. You can then make all the changes to that.

By default, all users are in the 'default' workflow. This is assigned through the web Desktop Administrator app (not the windows app) on a per-user basis, so just assign the new Workflow group you create to your test user.

Regards

Aaron

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Ok, I've gone through

Ok, I've gone through relevant parts in the manual and have made it farther.  I've created the new Work Flow Group, as you suggested.  I've created the Voice Contact Work Flow for the screen pop and configured it best I could figure out.  When I hit test (configured for a google search for testing), it seems to work.  However, when I place a test call and it hits the agent, nothing happens.  I get no screen pop and the integrated browser doesn't change.  I tested by adding more tabs and adding "Work Sites", and they show up as expected, but I still cannot get the screen pop to display.

Am I expecting it to do something it cannot?  I would like a window to pop up with some information that I define through Set Enterprise Data. Am I misunderstanding its capabilities?

Super Bronze

HiYou configure the actions,

Hi

You configure the actions, and then you have to assign them to the workflows based on conditions of the call.

For example - you might pass a variabel from the script, that tells CAD to use a different action (i.e. different pop) for different call types or so on. If you want all calls to just fire a standard action, you'd normally set it for any ANI.

E.g.

  • Voice workflows
  • 'Answered'
  • New... rule
  • 'Enabled rule' checked
  • Edit condition one, set 'calling#' is not empty
  • Then assign your action

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

I have been able to create an

I have been able to create an "Agent Notification" action that it works (pops up message box at Ringing and at Answered) and I've created a "Launch External Application" (at Ringing) step to open IE (as a test) that also works so I know I have my rules and conditions figured out.  That means the problem has to be with my "HTTP action" step or whatever allows that action to work.  Following steps I found in the guide, here is my HTTP action step:

Name: HTTP:Action_ScreenPop

Protocol: http

Method: Get (also tried Post)

Host: www.google.com

Port: 80

Path: search

Browser tab: HTTP Web Browser Tab 1

Request Data:

Name/Value/Value Type

hl/en/UserDefined

source/hp/UserDefined

q/cisco systems/UserDefined

gbv/2/UserDefined

oq/cisco systems/UserDefined

With all of those settings, I can hit Test button and I get an IE window to pop up that takes me to a google search for Cisco Systems.  However, going through the process live, I get nothing.  Any thoughts on what I'm missing?

Super Bronze

HiDo you have the built-in

Hi

Do you have the built-in browser enabled?

HTTP Actions trigger the internal browser. 

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

If you are referring to the

If you are referring to the "Enable Integrated Browser" setting in the "User Interface" section of the WFG, then yes, I have that checked.  I have also added a tab to make sure that part is configured correctly.  If it matters, the "Number of workflow browsers" is set to 1.

Super Bronze

Can you  check the logs in

Can you  check the logs in the 'log' folder in the CAD directory on the client?

If there's nothing interesting in there you may have to increase the logging level in the .ini/cfg file.
Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

I'm not exactly sure what I

I'm not exactly sure what I did, but it started working.  The tab opens in the integrated browser and goes to the page I tell it to go to.  From here, to display a customized webpage that shows ONLY the data I want it to show (provided by the enterprise data), do I have to create a form, store it on a webserver, and then direct the HTTPAccess action to that location?

I also wanted to confirm something you had mentioned before.  This only works for opening the information in a tab within CAD, not a browser external to CAD.  Is that correct?

Super Bronze

HiYes, that's all correct -

Hi

Yes, that's all correct - to automate external browsers you'd use key macros or one of the other options as with any other external applicaiton you'd like to control.

Regards

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
353
Views
10
Helpful
11
Replies
CreatePlease to create content