Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ICM 9.0 Web Setup Error

The web setup, cce admin & reskill tool are not working.

When I try websetup and cceadmin with https, it says service unavailable. When I try only with http, I am getting IIS error.

When I try reskill, I am getting IIS error.

  • Is this a fresh installation of ICM?
    • Upgrade from 8.5.4 to 9.0.1       and patch 9.0.4
  • Which ICM version you are trying to run the setup for?
    • Uninstalled 9.0.4, removed       tomcat 7 from add or remove programs (after uninstalling from add or       remove programs, it is still showing in services.msc).
    • Run ICM set up 9.0.1
  • A screenshot of windows Add\Remove programs.
    • Attached
  • A screenshot showing the error message which you are      facing while running ICM web-setup.
    • Attached

Also I see following error in Tomcat logs.

ISAPI:

[Mon Feb 24 11:03:47.857 2014] [5220:1732] [error] ajp_send_request::jk_ajp_common.c (1630): (worker.tomcat) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=61)

[Mon Feb 24 11:03:48.958 2014] [5220:1732] [error] ajp_send_request::jk_ajp_common.c (1630): (worker.tomcat) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=61)

[Mon Feb 24 11:03:48.959 2014] [5220:1732] [error] ajp_service::jk_ajp_common.c (2626): (worker.tomcat) connecting to tomcat failed.

[Mon Feb 24 11:03:48.960 2014] [5220:1732] [error] HttpExtensionProc::jk_isapi_plugin.c (2261): service() failed with http error 503

Commons daemon:

[2014-02-24 10:56:28] [info]  Commons Daemon procrun (1.0.8.0 64-bit) started

[2014-02-24 10:56:28] [info]  Running 'Tomcat7' Service...

[2014-02-24 10:56:28] [info]  Starting service...

[2014-02-24 10:56:28] [error] %1 is not a valid Win32 application.

[2014-02-24 10:56:28] [error] Failed creating java C:\jre1.6.0_30\bin\client\jvm.dll

[2014-02-24 10:56:28] [error] %1 is not a valid Win32 application.

[2014-02-24 10:56:28] [error] ServiceStart returned 1

[2014-02-24 10:56:28] [error] %1 is not a valid Win32 application.

[2014-02-24 10:56:28] [info]  Run service finished.

[2014-02-24 10:56:28] [info]  Commons Daemon procrun finished


1 ACCEPTED SOLUTION

Accepted Solutions
New Member

ICM 9.0 Web Setup Error

In looking at this further, the path didn't change with the SR 3 update, but when MS patches were applied along with a Java update from jre6_30 to jre6_45.

11 REPLIES

Re: ICM 9.0 Web Setup Error

Hi,

this cannot be asked nicely, but anyway, why did you uninstall the Tomcat application?

This way: Tomcat is an application container. The webserver is optional. Tomcat is packaged with the Catalina web server, but can cooperate with Microsoft IIS as the web server, and for some reason, Cisco ICM follows this design choice.

So when you uninstalled Tomcat, you removed only the part of it, but it apparently, made things a bit worse. Anyway, can you please tell us why this uninstall?

G.

Message was edited by: Gergely Szabo: typo

New Member

ICM 9.0 Web Setup Error

When i found this issue, i checked whether Apache tomcat 7 service is started in services.msc. But the Apache Tomcat service was in stopped state.

When i tried to start, it was not starting. Due to which i unstalled Apache Tomcat 7 from add or remove programs.

ICM 9.0 Web Setup Error

Hi,

just curious: what would be your next step? You uninstalled Tomcat, and then - what?

Thanks.

G.

New Member

ICM 9.0 Web Setup Error

I did not have any other idea till now. I have raised TAC case for now.

ICM 9.0 Web Setup Error

Please do post back your findings, I really want to see how to get out of this situation.

Thanks.

G.

Silver

ICM 9.0 Web Setup Error

I'm curious... is msvcr71.dll in C:\Windows\SysWOW64 ?

New Member

ICM 9.0 Web Setup Error

Yes Omar, the msvcr71.dll is there in the location.

New Member

ICM 9.0 Web Setup Error

I ran into this same issue this morning on 9.0(3). I went into the Apache Tomact 7 properties (C:\icm\tomcat\bin\tomcatyw.exe) and looked at the Java tab. For the Java Virtual Machine path, it was set to C:\jre1.6.0_30\bin\client\jvm.dll, however that path did exist. I found the jvm.dll file under C:\program files\java\jre6\bin\client\jvm.dll so I updated the path in the Apache Tomcat properties to this location. Once that was done I was able to start tomcat with out issue and websetup is now accessible.

ICM 9.0 Web Setup Error

Christian, did you talk to TAC about this? It would be important to see whether this is a bug.

Thanks.

G.

New Member

ICM 9.0 Web Setup Error

In looking at this further, the path didn't change with the SR 3 update, but when MS patches were applied along with a Java update from jre6_30 to jre6_45.

New Member

ICM 9.0 Web Setup Error

Christion - You are right. Now i have rebuilt the server without any updates on the server and everything is working fine.

790
Views
5
Helpful
11
Replies
CreatePlease to create content