Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ICM detects patch that doesn't exist

We did maintenance over ICM 6.0 SR9, to add new PG on the same hardware, so we un-install SR9, and ran 'setup.exe' from CD media, it kept popping uo alarm "ICM detects patch installed", so asked to un-install patch before running setup, then aborted the installtion program. However, I could not find where it got this information, the verison file under c:\icm show the base version, and no patch is under registry key as well. the icmsetup.log shows nothing on whereabout of the patch level. Eventually, I have to remove all ICM folder and registry keys, then re-installed the whole ICM on this node.

I wonder if anyone got the same problem like this, and know how ICM setup finds the patch?

Wei

2 REPLIES
New Member

Re: ICM detects patch that doesn't exist

I ran into a somewhat related issue before. I redeployed a PG on a version 5 ICM system, uninstalled all of the software, moved it to a new location, then reran the software install from CD media. Even though it should have been a fresh, new install, it still found references to previous location (PG number, etc.). When I went to Cisco, they said that they don't support this type of redeployment, so while I wasn't able to get a final answer, there definately are files, probably in registry like you said, that are still in existence after you uninstall. We didn't pursue it much further since it eventually worked, so I don't have a definitive answer for you, sorry.

Cisco Employee

Re: ICM detects patch that doesn't exist

Hi there,

In regedit, go to HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\Patch\ICM\6.0\Patch check on the "CurrentPatch" key value.

This was probably the result of removing SR and thus, the installer is confused as to what the patch version is on the server.

To fix it follow the same workaround proposed in CSCsb91944, with the reference to the proper ICM Version.

Symptom:

When trying to install an SR, the SR claims that you are not at the correct base level for the patch.

Conditions:

A previous SR has been uninstalled and the registry changes did not complete properly.

Workaround:

Use regedit to delete the key:

HKLM\SOFTWARE\Cisco Systems, Inc.\Patch

Or, copy the Patch\ICM\7.0\ICM_7_0_0_0_0_0_0\Base value to the Patch\ICM\7.0\Patch\CurrentPatch value, if

you have other products installed on the system and do not want to lose their patch info state.

This should do.

Regards,

Riccardo

PS Please rate useful posts.

121
Views
0
Helpful
2
Replies
CreatePlease to create content