Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ICM Script Editor 'Search' 'Find' function, won't stop. Bug? 8.5.2

Script Editor issue; UCCE 8.5.2

When I use the "Find Nodes" function in script editor, to find a string in 'all active scripts' the results are displayed eventually. Once displayed though, the search immediately begins again, preventing selection of any of the results.

It feels like a bug, & has a huge impact on usability of the search feature. It can also occasionally cause scripted.exe to crash.

I think it is likely because there are a large number of scripts in our environment, but there is no way around that right now.

I was considering opening a TAC, but thought there may be simple fix in the wild that someone could share here.

Is there a way to extend the refresh period for the search function? Or can the automatic refresh be disabled entirely?

Appreciate any help, thanks in advance.

Edwin

  • Contact Center
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

If there are many updates

If there are many updates going on it can be frustrating. I found as a work around  that you can create or open a script and have it in edit mode. Then when you do a search it only cycles once.  
 

9 REPLIES

Edwin,I'm using 8.5.4, and I

Edwin,

I'm using 8.5.4, and I am not seeing that bug.

-Jameson

-Jameson
New Member

James, I use 8.0.3, facing

James, 

I use 8.0.3, facing the same above issue. Any inputs would be much helpful.

I think I ran into something

I think I ran into something similar many years ago and it was a bug, but I can't find any notes on it. I would go ahead and open a TAC case. Does this happen even when your search criteria is very specific?

 

david

New Member

The search produces the

The search produces the results in the pop up sub-window, and before you can do anything, the pop up dissappears, and the search begins all over again.

Like I said, I suspect that it may be related to the size and number of scripts to be searched. There are a great deal of large scripts in our environment. The length of time required to search all scripts, approaches the automatic reload interval of the Script Editor's configuration.

I am curious, h12490, how many scripts you have.

New Member

Were you able to find a fix

Were you able to find a fix for this issue or did you ever open a case with TAC?  We are having this issue as well it seems along with another problem that recently started where certain updates that are made in CCMP load one at a time instead of as a bulk update in UCCE. 

The example I was shown today by two end users was where one did an update of 93 Agent Desktops in CCMP and while viewing the other users Script Editor on an AW the update process to refresh the config within ICM occurred as normal then again and again for guessing around 92 more times in a row which basically stops all work in Script Editor till the config refresh is completed.  It looks like it is loading only one update at a time instead of all of them at once.  I do not know if this has to do with the type of resource being updated (in this case Agent Desktop settings) or not but it doesn't seem to happen with say Agent moves so far.  So for a very large company like ours this can have a huge impact to script updates and configuration changes.

If you can update on how you either resolved this or if a case was opened what the number for the ticket was I can reference that with the support case I will be opening for this.  

Thanks in advance! 

New Member

If there are many updates

If there are many updates going on it can be frustrating. I found as a work around  that you can create or open a script and have it in edit mode. Then when you do a search it only cycles once.  
 

New Member

Theodore,Your work-around

Theodore,

Your work-around DOES appear to work in my environment as well, thanks very much! With any single script in edit mode, the search function only cycles one time.

While this may remain a bug, I am going to mark your answer as 'correct'.

Thanks again for your help.

Edwin

New Member

Hi,  My case, we have 8.0.3,

Hi, 

 

My case, we have 8.0.3, when ever we do some microsoft update on server once in a month we use to reboot the AW as its happening to it. And before reboot we are stopping AW services and after reboot starting it.

Once the services get started we are facing this issue and this issue exists only few days amy be a week. then its becoming normal and starts up again on next month update activity.

Any body facing in same way?

 

New Member

Have you tried to see if this

Have you tried to see if this happens at low activity points in the call centers (i.e. overnight/early morning)? We ran into a similar situation once and it turned out that there were a couple supervisors who were making edits to agent attributes/skills one at a time surprisingly often. By the time the search was about to complete in Script Editor, the supervisor had changed another agent, so the process started all over again.

And have you tried this search on more than one AW/HDS?

186
Views
5
Helpful
9
Replies